蓝桥杯_基础练习 十六进制转十进制

问题描述
  从键盘输入一个不超过8位的正的十六进制数字符串,将它转换为正的十进制数后输出。
  注:十六进制数中的10~15分别用大写的英文字母A、B、C、D、E、F表示。
样例输入
FFFF
样例输出
65535
#include<memory>
#include<iostream>
#include<string>
#include<cctype>
#include<algorithm>
#include<cmath>
#include<ctime>
#include<cstdlib>
#include<cstdio>
#include<sstream>
using namespace std;
bool to16_10(std::string& word ){

    long long count = 0;
    for (unsigned int var1 = 0; var1 < word.length (); ++var1) {
        if(word.at(var1) >= '0' && word.at (var1) <= '9'){
            count  = 16*count + (word.at (var1) - '0');
        }
        else if(word.at(var1) >= 'A' && word.at (var1) <= 'F'){
            count  = 16*count + (word.at (var1) - 'A'+10);
        }

    }
    std::stringstream ss;
    ss << count;
    ss >> word;
    return true;
}

int main(int argc, char *argv[])
{
    string word;

    cin >> word;
    to16_10 (word);

    cout <<word <<endl;

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值