元素为set的map ip&qq

An ip can login several qqs, and a qq can be logined by several ips.

Your task is to find which qqs have been logined by the ip and which ips have logined the qq.

output format : $qq ==> [ $ip1 $ip2 ... ]  and $ip ==> [ $qq1 $qq2 ... ]

if no such qq or ip, output "no qq" and "no ip"

First input n, then n+2 lines follow..

n lines:

$qq $ip

2 lines:

$ip  // find which qqs have been logined by the ip

$qq  // find which ips have logined the qq.

 

sample input:

5
10258279649 192.168.1.45
10258279649 192.168.1.45
10258279643 192.168.1.40
10258279640 192.168.1.45
10258279641 192.168.1.30
192.168.1.45
10258279649

sample output:

192.168.1.45 ==> [ 10258279640 10258279649 ]
10258279649 ==> [ 192.168.1.45 ]

#include <iostream>
#include <map>
#include <set>
using namespace std;

int main() {
    map<string, set<string> > itq;  //  key is ip
    map<string, set<string> > qti;  //  key is qq

    string qq, ip;
    int n = 0;
    cin >> n;
    for (int i = 0; i < n; i++) {
        cin >> qq >> ip;
        itq[ip].insert(qq);   //  ip is the key
        qti[qq].insert(ip);   //   qq is the key
    }

    set<string>::iterator b;  //  一个key下对应的多个
    cin >> ip;
    if (itq.find(ip) == itq.end()) {
        cout << "no qq" << endl;
    } else {
        cout << ip <<  " ==> [ ";
        for (b = itq[ip].begin(); b != itq[ip].end(); b++) {
            cout << *b << " ";  //  输出一个ip对应的多个qq
        }
        cout << "]" << endl;
    }

    cin >> qq;
    if (qti.find(qq) == qti.end()) {
        cout << "no ip" << endl;
    } else {
        cout << qq << " ==> [ ";
        for (b = qti[qq].begin(); b != qti[qq].end(); b++) {
            cout << *b << " ";  //  输出一个qq对应的多个ip
        }
        cout << "]" << endl;
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值