poj 1988 Cube Stacking 并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 18512 Accepted: 6424
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations:
moves and counts.
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y.
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value.

Write a program that can verify the results of the game.

Input

* Line 1: A single integer, P

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X.

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself.

Output

Print the output from each of the count operations in the same order as the input file.

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<string>
#include<iostream>
#include<algorithm>
#include<vector>
#include<queue>
#include<list>
#include<map>
#include<set>
using namespace std;
const int N = 30000;
int f[N+10];
int child[N+10];
int top[N+10];
int set_find(int x){
    if(x==f[x]) return x;
    int pre=f[x];
    f[x]=set_find(f[x]);
    child[x]+=child[pre];
    return f[x];
}

void set_join(int x,int y){
    x=set_find(x);
    y=set_find(y);
    f[x]=y;
    set_find(top[y]);
    child[x]+=child[top[y]]+1;
    top[y]=top[x];
}
int main()
{

//	freopen("in.in","r",stdin);
    int T;
    scanf("%d",&T);
    getchar();
    for(int i=1;i<=N;i++){
        f[i]=i;
        child[i]=0;
        top[i]=i;
    }
    int x,y;
    char s;
    while(T--){
        scanf("%c",&s);
        if(s=='M'){
            scanf("%d%d",&x,&y);
            getchar();
            set_join(x,y);
        }
        else {
            scanf("%d",&x);
            getchar();
            set_find(x);
            printf("%d\n",child[x]);
        }
    }


	return 0;
}





 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值