POJ 1656 二维树状数组简单应用

11 篇文章 0 订阅

一个水题。。。结果因为一个加号写成了减号。。。硬是耗费了一个多小时。。。T^T


Counting Black
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 10012   Accepted: 6466

Description

There is a board with 100 * 100 grids as shown below. The left-top gird is denoted as (1, 1) and the right-bottom grid is (100, 100). 

We may apply three commands to the board: 
1.	WHITE  x, y, L     // Paint a white square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



2.	BLACK  x, y, L     // Paint a black square on the board, 

                           // the square is defined by left-top grid (x, y)

                           // and right-bottom grid (x+L-1, y+L-1)



3.	TEST     x, y, L    // Ask for the number of black grids 

                            // in the square (x, y)- (x+L-1, y+L-1) 

In the beginning, all the grids on the board are white. We apply a series of commands to the board. Your task is to write a program to give the numbers of black grids within a required region when a TEST command is applied. 

Input

The first line of the input is an integer t (1 <= t <= 100), representing the number of commands. In each of the following lines, there is a command. Assume all the commands are legal which means that they won't try to paint/test the grids outside the board.

Output

For each TEST command, print a line with the number of black grids in the required region.

Sample Input

5
BLACK 1 1 2
BLACK 2 2 2
TEST 1 1 3
WHITE 2 1 1
TEST 1 1 3

Sample Output

7
6


就是多次统计某一个区域里黑色方块的数量,有人说用直接模拟就能过去。。。我没试。。。为了保险还是用树状数组撸了。。。

用一个atlas数组来记录某一个状态时黑白方块的数量(奇怪的是。。我用bool数组的话 time是16ms。。。如果是int数组的话 time是0ms。。。)atlas[i][j]为1表示black,为0表示white。

然后一次一次查询时修改即可。

至于二维树状数组的写法,只要在一维的基础上加一层循环即可。

下面放出代码

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <string>
#include <cstring>
#include <algorithm>
#include <numeric>
#include <vector>
#include <queue>
#include <stack>

using namespace std;

#define MAX_N 101

int bintree[MAX_N][MAX_N] = { 0 };
int atlas[MAX_N][MAX_N] = { 0 };

int lowbit(int pos) {
    return pos & (-pos);
}

int getsum(int xpos, int ypos) {
    int sum = 0;
    while(xpos > 0) {
        int yypos = ypos;
        while(yypos > 0)
            sum += bintree[xpos][yypos], yypos-=lowbit(yypos);
        xpos -= lowbit(xpos);
    }
    return sum;
}


void update(int xpos, int ypos, int val) {
    while(xpos <= 100) {
        int yypos = ypos;
        while(yypos <= 100)
            bintree[xpos][yypos] += val, yypos += lowbit(yypos);
        xpos += lowbit(xpos);
    }
}

int main() {
    int test_n, x, y, l;
    string order;
    cin >> test_n;
    while(test_n--) {
        cin >> order >> x >> y >> l;
        if(order == "BLACK") {
            for(int i = x; i <= x + l - 1; i++) {
                for(int j = y; j <= y + l - 1; j++) {
                    if(atlas[i][j] == 0)
                        update(i, j, 1), atlas[i][j] = 1;
                }
            }
        }
        else if(order == "WHITE") {
            for(int i = x; i <= x + l - 1; i++) {
                for(int j = y; j <= y + l - 1; j++) {
                    if(atlas[i][j] == 1)
                        update(i, j, -1), atlas[i][j] = 0;
                }
            }
        }
        else
            printf("%d\n", getsum(x + l - 1, y + l - 1) + getsum(x - 1, y - 1) - getsum(x - 1, y + l - 1) - getsum(x + l - 1, y - 1));
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值