poj 2796 利用并查集维护区间和



题目出自Northeastern Europe 2005 poj上的链接是http://poj.org/problem?id=2796


下面放出题目

Feel Good
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 8889   Accepted: 2413
Case Time Limit: 1000MS   Special Judge

Description

Bill is developing a new mathematical theory for human emotions. His recent investigations are dedicated to studying how good or bad days influent people's memories about some period of life. 

A new idea Bill has recently developed assigns a non-negative integer value to each day of human life. 

Bill calls this value the emotional value of the day. The greater the emotional value is, the better the daywas. Bill suggests that the value of some period of human life is proportional to the sum of the emotional values of the days in the given period, multiplied by the smallest emotional value of the day in it. This schema reflects that good on average period can be greatly spoiled by one very bad day. 

Now Bill is planning to investigate his own life and find the period of his life that had the greatest value. Help him to do so.

Input

The first line of the input contains n - the number of days of Bill's life he is planning to investigate(1 <= n <= 100 000). The rest of the file contains n integer numbers a1, a2, ... an ranging from 0 to 106 - the emotional values of the days. Numbers are separated by spaces and/or line breaks.

Output

Print the greatest value of some period of Bill's life in the first line. And on the second line print two numbers l and r such that the period from l-th to r-th day of Bill's life(inclusive) has the greatest possible value. If there are multiple periods with the greatest possible value,then print any one of them.

Sample Input

6
3 1 6 4 5 2

Sample Output

60
3 5

这个题可以考虑使用并查集。

首先将这些点按大小排序。然后逐个遍历,每次遍历时,查看它是否可以和左右两个区间合并。是否合并的判断可以通过判断这个点的大小和左右两个区间中最小值的比较来进行,哪一边的最小值比它大,那么就将它并入那一边的区间,并更新区间和以及区间的最小的数。结束两个判断后,便求一次 a[i]*区间和 并更新答案即可。

下面放出代码

#include <vector>
#include <list>
#include <map>
#include <set>
#include <deque>
#include <queue>
#include <stack>
#include <bitset>
#include <algorithm>
#include <functional>
#include <numeric>
#include <utility>
#include <sstream>
#include <iostream>
#include <iomanip>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <cctype>
#include <string>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <cstdlib>
#include <ctime>
#define max(a,b) ((a)>(b)?(a):(b))
#define min(a,b) ((a)>(b)?(b):(a))
#define rep(i,initial_n,end_n) for(int (i)=(initial_n);(i)<(end_n);i++)
#define repp(i,initial_n,end_n) for(int (i)=(initial_n);(i)<=(end_n);(i)++)
#define reep(i,initial_n,end_n) for((i)=(initial_n);(i)<(end_n);i++)
#define reepp(i,initial_n,end_n) for((i)=(initial_n);(i)<=(end_n);(i)++)
#define eps 1.0e-9
#define MAX_N 1010

using namespace std;
typedef pair<int, int> pii;
typedef pair<double, double> pdd;
typedef __int64 ll;
typedef unsigned __int64 ull;

struct node {
    int num, n;
    friend bool operator < (node a, node b) {
        return a.num > b.num;
    }
};

node a[100010];
int minn[100010], l[100010], r[100010], p[100010];
ll sum[100010];
int find(int i);
void merge(int x, int y);

int main() {
    int n;
    while(scanf("%d", &n) > 0) {
        sum[0] = 0;
        repp(i, 1, n) {
            scanf("%d", &a[i].num);
            a[i].n = i;
            minn[i] = a[i].num;
            l[i] = i, r[i] = i;
            sum[i] = sum[i - 1] + a[i].num;
        }
        sort(a + 1, a + 1 + n);
        ll ans = 0;
        int ansr = 1, ansl = 1;
        repp(i, 0, n) p[i] = i;
        repp(i, 1, n) {
            //printf("n = %d num = %d minn[%d] = %d\n", a[i].n, a[i].num, a[i].n - 1, minn[find(a[i].n - 1)]);
            if(a[i].n > 1 && minn[find(a[i].n - 1)] >= a[i].num){
                //puts("YES");
                merge(a[i].n - 1, a[i].n);
            }
            //printf("n = %d num = %d minn[%d] = %d\n", a[i].n, a[i].num, a[i].n + 1, minn[find(a[i].n + 1)]);
            if(a[i].n < n && minn[find(a[i].n + 1)] >= a[i].num){
                //puts("YES");
                merge(a[i].n, a[i].n+1);
            }
            int ii = find(a[i].n);
            ll tmp = (ll)(sum[r[ii]] - sum[l[ii] - 1]) * minn[ii];
            //printf("tmp = %d r = %d l = %d min = %d ii = %d\n", tmp, r[ii], l[ii], minn[ii], ii);
            if(tmp > ans) ans = tmp, ansr = r[ii], ansl = l[ii];
        }
        printf("%I64d\n%d %d\n", ans, ansl, ansr);
    }
    return 0;
}

int find(int i) {
    return p[i] == i ? i : p[i] = find(p[i]);
}

void merge(int x, int y) {
    int xp = find(x), yp = find(y);
    p[xp] = yp;
    l[yp] = min(l[yp], l[xp]), r[yp] = max(r[yp], r[xp]);
    minn[yp] = min(minn[yp], minn[xp]);
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值