POJ 2488 A Knight's Journey

来源:http://poj.org/problem?id=2488


A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 30588 Accepted: 10479

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany


题意: 输出骑士遍历棋盘的路径,起点终点任意~ 要求路径的字典序要最小。如果无法遍历则输出impossible
 
题解: DFS 这里需要注意的字典序输出路径,开始我没查  lexicographically 是什么意思 第三组样例就过不了~~这里实现字典序,只要搜索顺序稍微注意下就好
int dir[8][2]={
{-1,-2},{1,-2},
{-2,-1}, {2,-1},
{-2,1},{2,1},
{-1,2},{1,2}
};
这样就可以保证字典序了~~

PS: 后来我还是WA了,错误发现后很无语 impossible打成 Impossible ~~以后坚决不手打!

//要字典序输出 
#include<cstdio>
#include<cstring>
const int Max=30;
struct Node{
	bool square;
	int prex,prey;
} map[Max][Max];
int t,x,y,endx,endy,squares,pos,posx[Max][2];
int dir[8][2]={
	{-1,-2},{1,-2},
	{-2,-1}, {2,-1},
	 {-2,1},{2,1},
	{-1,2},{1,2}
};
bool flag=false; 
void dfs(int dx,int dy,int step){
	if(step==x*y){
		endx=dx; endy=dy;
		flag=true;
		return;
	}
	for(int i=0;i<8&&!flag;i++){
		int tempx=dx+dir[i][0],tempy=dy+dir[i][1];
	if(tempx>=0&&tempx<x&&tempy>=0&&tempy<y&&map[tempx][tempy].square){
		map[tempx][tempy].square=false;
		map[tempx][tempy].prex=dx;map[tempx][tempy].prey=dy;
		dfs(tempx,tempy,step+1);
		map[tempx][tempy].square=true;
	}
	}		
}
void  init(){
	for(int i=0;i<x;i++)
	for(int j=0;j<y;j++)
	map[i][j].square=true;
}
int main(){
	scanf("%d",&t);
	for(int k=1;k<=t;k++){
	scanf("%d%d",&x,&y);  squares=x*y;flag=false; 
	printf("Scenario #%d:\n",k);
	for(int i=0;i<x&&!flag;i++)
	for(int j=0;j<y&&!flag;j++){
		init( );      //初始化棋盘 
		map[i][j].prex=map[i][j].prey=-1;map[i][j].square=false;
		dfs(i,j,1);
		if(flag){  //成功 
		int px=endx,py=endy; pos=0;
		posx[pos][0]=px;posx[pos++][1]=py;
		//printf("%c%d",endx+'A',endy+1);
		while(map[px][py].prex!=-1&&map[px][py].prey!=-1){
		int tempx=px;
		px=map[px][py].prex;py=map[tempx][py].prey;
		posx[pos][0]=px;posx[pos++][1]=py;
		}
		for(int z=pos-1;z>=0;z--)
		printf("%c%d",posx[z][1]+'A',posx[z][0]+1);
		break;		
		}
	}
	if(!flag){//失败 
		printf("impossible");	
	} 
	printf("\n\n");
	}
	return 0;
}



 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值