HDOJ 4499 Cannon

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4499


Cannon

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 513    Accepted Submission(s): 297


Problem Description
In Chinese Chess, there is one kind of powerful chessmen called Cannon. It can move horizontally or vertically along the chess grid. At each move, it can either simply move to another empty cell in the same line without any other chessman along the route or perform an eat action. The eat action, however, is the main concern in this problem. 
An eat action, for example, Cannon A eating chessman B, requires two conditions: 
1、A and B is in either the same row or the same column in the chess grid. 
2、There is exactly one chessman between A and B. 
Here comes the problem. 
Given an N x M chess grid, with some existing chessmen on it, you need put maximum cannon pieces into the grid, satisfying that any two cannons are not able to eat each other. It is worth nothing that we only account the cannon pieces you put in the grid, and no two pieces shares the same cell.
 

Input
There are multiple test cases. 
In each test case, there are three positive integers N, M and Q (1<= N, M<=5, 0<=Q <= N x M) in the first line, indicating the row number, column number of the grid, and the number of the existing chessmen. 
In the second line, there are Q pairs of integers. Each pair of integers X, Y indicates the row index and the column index of the piece. Row indexes are numbered from 0 to N-1, and column indexes are numbered from 0 to M-1. It guarantees no pieces share the same cell.
 

Output
There is only one line for each test case, containing the maximum number of cannons.
 

Sample Input
      
      
4 4 2 1 1 1 2 5 5 8 0 0 1 0 1 1 2 0 2 3 3 1 3 2 4 0
 

Sample Output
      
      
8 9
 

Source

题意:给定一个棋盘,以及棋子的位置,问在该棋盘上最多还能放多少个棋子"炮",并且要保证"炮"之间不能相互攻击。

题解:可以用搜索做,从左至右,从上至下摆棋子,每次都要判断该点是否可以摆放。

——开始一直WA/TLE  郁闷——又稀里糊涂的过了~~ 果断时间再来看看。

AC代码:

#include<iostream>
#include<cstring>
#define N 6
using namespace std;
int init[N][N];
int n,m,q,tx,ty,res;
bool check(int x,int y){
    if(init[x][y])return false;
   init[x][y]=2;
    for(int i=0;i<y-1;i++){
        if(init[x][i]==2){
            int k=i+1,flag=0;
            while(k<=y){
                if(init[x][k]==2&&flag){
                        init[x][y]=0;return false;
                }
                if(init[x][k]>0)flag++;
                if(flag>1)break;
                k++;
            }
        }
    }
    for(int i=0;i<x-1;i++){
        if(init[i][y]==2){
            int k=i+1,flag=0;
            while(k<=x){
                if(init[k][y]==2&&flag){
                    init[x][y]=0;return false;
                }
                if(init[k][y]>0)flag++;
               if(flag>1)break;
                k++;
            }
        }
    }
    init[x][y]=0;
    return true;
}
void dfs(int x,int y,int cnt){
    if(cnt>res)res=cnt;
     if(y==m){
        x++;y=0;
        if(x>=n)return;
    }
    for(int i=x;i<n;i++)
    for(int j=y;j<m;j++){
        if(check(i,j)){
            init[i][j]=2;
            dfs(i,j+1,cnt+1);
            init[i][j]=0;
        }
        return dfs(i,j+1,cnt);
    }
}
int main()
{
    cin.sync_with_stdio(false);
    while(cin>>n>>m>>q)
    {
        res=0;
        memset(init,0,sizeof(init));
        while(q--){
            cin>>tx>>ty; init[tx][ty]=1;
        }
        dfs(0,0,0);
        cout<<res<<endl;
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值