nyoj-130 相同的雪花 (哈希)

相同的雪花

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 4
描述
You may have heard that no two snowflakes are alike. Your task is to write a program to determine whether this is really true. Your program will read information about a collection of snowflakes, and search for a pair that may be identical. Each snowflake has six arms. For each snowflake, your program will be provided with a measurement of the length of each of the six arms. Any pair of snowflakes which have the same lengths of corresponding arms should be flagged by your program as possibly identical.
输入
The first line of the input will contain a single interger T(0<T<10),the number of the test cases.
The first line of every test case will contain a single integer n, 0 < n ≤ 100000, the number of snowflakes to follow. This will be followed by n lines, each describing a snowflake. Each snowflake will be described by a line containing six integers (each integer is at least 0 and less than 10000000), the lengths of the arms of the snow ake. The lengths of the arms will be given in order around the snowflake (either clockwise or counterclockwise), but they may begin with any of the six arms. For example, the same snowflake could be described as 1 2 3 4 5 6 or 4 3 2 1 6 5.
输出
For each test case,if all of the snowflakes are distinct, your program should print the message:
No two snowflakes are alike.
If there is a pair of possibly identical snow akes, your program should print the message:
Twin snowflakes found.
样例输入
1
2
1 2 3 4 5 6
4 3 2 1 6 5
样例输出
Twin snowflakes found.


思路:

        此题数据量很大, 如果是挨个枚举两朵雪花是否一致的话,肯定会超时. 但如果能先求出六条边的和,判断时只跟和相等的雪花进行比较,明显会好很多了。但是,需要注意的是这个和也可能很大。。所以,就可以先取余了~ 


代码:

#include <stdio.h>
#include <string.h>
#include <vector>
#define N 100000

using namespace std;

struct Node{
	int num[6];
	int s;				// 保存 num 数组所有数据的和,以提高效率 
};

bool CMP(int a[], int b[]){				// 比较函数 
	int start = -1, ok = 0;
	while(start < 6 && ok == 0){		// 找到一个相同点的位置(注意,某雪花的两条边可能相等) 
		for(start += 1; ; start ++){
			if(start >= 6){
				return 0;
			}
			if(a[start] == b[0]){
				break;	
			}
		}
		
		ok = 1;
		for(int i = 0, j = start; i < 6; i ++, j ++){				// 正向比较 
			if(b[i] != a[j % 6]){
				ok = 0;
				break;
			}
		}
		if(!ok){
			ok = 1;
			for(int i = 0, j = start + 6; i < 6; i ++, j --){		// 逆向比较 
				if(b[i] != a[j % 6]){
					ok = 0;
					break;
				}
			}
		}
	}
	
	return ok;
}

int main(){
	int loop, n;
	scanf("%d", &loop);
	while(loop --){
		Node nw, cur;
		vector<Node>p[N];		
		int ok = 0;
		
		scanf("%d", &n);
		while(n -- ){
			int s = 0;			// 记录和 
			for(int i = 0; i < 6; i ++){
				scanf("%d", &nw.num[i]);
				s += nw.num[i];
			}
			nw.s = s;			
			s %= N;				// 取余的原因是 s太大,数组开不了 
			
			if(!ok){
				for(int i = 0; i < p[s].size(); i ++){
					if(nw.s != p[s].at(i).s){			// 比较两朵雪花的边和是否一样 
						continue;
					}
					
					cur = p[s].at(i);
					ok = CMP(nw.num, cur.num);			// 比较边 
					if(ok){
						break;
					}
				}
				if(!ok){
					p[s].push_back(nw);
				}
			}
		}
		
		if(ok){
			printf("Twin snowflakes found.\n");
		}
		else{
			printf("No two snowflakes are alike.\n");
		}
	}
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值