poj2531_Network Saboteur

Network Saboteur
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8538 Accepted: 3950

Description

A university network is composed of N computers. System administrators gathered information on the traffic between nodes, and carefully divided the network into two subnetworks in order to minimize traffic between parts.  
A disgruntled computer science student Vasya, after being expelled from the university, decided to have his revenge. He hacked into the university network and decided to reassign computers to maximize the traffic between two subnetworks.  
Unfortunately, he found that calculating such worst subdivision is one of those problems he, being a student, failed to solve. So he asks you, a more successful CS student, to help him.  
The traffic data are given in the form of matrix C, where Cij is the amount of data sent between ith and jth nodes (Cij = Cji, Cii = 0). The goal is to divide the network nodes into the two disjointed subsets A and B so as to maximize the sum ∑Cij (i∈A,j∈B).

Input

The first line of input contains a number of nodes N (2 <= N <= 20). The following N lines, containing N space-separated integers each, represent the traffic matrix C (0 <= Cij <= 10000).  
Output file must contain a single integer -- the maximum traffic between the subnetworks.  

Output

Output must contain a single integer -- the maximum traffic between the subnetworks.

Sample Input

3
0 50 30
50 0 40
30 40 0

Sample Output

90

分析: 将所有节点分成两个集合,求一个集合的各个节点到另一个集合各个节点的和的最大值。
dfs深搜,当前节点选入哪个集合。

#include <iostream>
#include <cstdio>
using namespace std;

int map[25][25];
int n;
int yes[25], no[25];
int mmax, yesnum, nonum;

void dfs(int num)
{
	int sum = 0;
	if (num == n)//选完了,求和
	{
		for (int i = 0; i < yesnum; i++)
		{
			for (int j = 0 ; j < nonum; j++)
				sum += map[yes[i]][no[j]];
		}
		if (mmax < sum)//更新最大值
			mmax = sum;
		return ;
	}
	yes[yesnum++] = num;//选入一个集合
	dfs(num+ 1);
	yesnum--;
	no[nonum++] = num;//选入另一个集合
	dfs(num + 1);
	nonum --;
}

int main()
{
	scanf("%d", &n);
	for (int i = 0; i < n; i++)
		for (int j = 0; j < n; j++)
			scanf("%d", &map[i][j]);
	dfs(0);
	printf("%d\n", mmax);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值