最大连续子序列和的O(n)算法

最大连续子序列和的O(n)算法

题目描述:

Given a sequence of K integers { N1, N2, ..., NK }. A continuous subsequence is defined to be { Ni, Ni+1, ..., Nj } where 1 <= i <= j <= K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.

Input Specification:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (<= 10000). The second line contains K numbers, separated by a space.

Output Specification:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.

Sample Input:
10
-10 1 2 3 4 -5 -23 3 7 -21
Sample Output:
10 1 4

解法一:O(n*n)时间复杂度
AC代码:
#include<cstdio>
#define MAX 10001

using namespace std;

int main(int argc,char *argv[])
{
	int n,sum=0;
	int max=0,flag=1;
	int Array[MAX];
	int i,j,begin,end;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&Array[i]);
		if(Array[i]>=0)
			flag=0;
	}
	max=0;
	for(i=0;i<n;i++)
	{
		sum=0;
		for(j=i;j<n;j++)
		{
			sum=sum+Array[j];
			if(sum>max)
			{
				max=sum;
				begin=Array[i];
				end=Array[j];
			}
		}
	}
	if(flag)
		printf("%d %d %d\n",0,Array[0],Array[n-1]);
	else
		printf("%d %d %d\n",max,begin,end);
	
	return 0;
}

解法二:O(n)算法
AC代码:
#include<cstdio>
#define MAX 10001

using namespace std;

int main(int argc,char *argv[])
{
	int n,sum,temp;
	int max,flag=1;
	int Array[MAX];
	int i,j,begin,end;
	scanf("%d",&n);
	for(i=0;i<n;i++)
	{
		scanf("%d",&Array[i]);
		if(Array[i]>=0)
			flag=0;
	}
	max=sum=Array[0];
	begin=end=temp=0;
	for(i=1;i<n;i++)
	{
	    if(sum<0)
		{
			sum=0;
			temp=i;
		}
		sum=sum+Array[i];
		if(sum>max)
		{
			max=sum;
			begin=temp;
			end=i;
		}
	}
	if(flag)
		printf("%d %d %d\n",0,Array[0],Array[n-1]);
	else
		printf("%d %d %d\n",max,Array[begin],Array[end]);
	
	return 0;
}

非常短,而且一眼就看出算法复杂度是O( n )级别的。

我们用i表示子序列的起始下标,j 表示子序列的终止下标。

原理是,当我们得到一个子序列,如果子序列的第一个数是非正数,那么可以舍去,即i++

当一个子序列的前n个元素和为非正数时,是否也可以舍去呢?答案是可以的。

假设k 是i到j中任意一个下标。Sum( a, b ) 表示子序列第a个元素到第b个元素之和。由于加到第j个元素,子序列才开始为负数,所以Sum( i, k ) > 0,Sum( i, k ) + Sum( k, j ) = Sum( i, j ) ,所以Sum( k, j ) < Sum( i, j ) < 0

所以如果把 k到j的序列附加到j之后的序列上,只会使序列越来越小。所以i到j的序列都可以舍去。



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值