Pat(Advanced Level)Practice--1030(Travel Plan)

Pat1030代码

题目描述:

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (<=500) is the number of cities (and hence the cities are numbered from 0 to N-1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input
4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20
Sample Output
0 2 3 3 40

AC代码:
#include<cstdio>
#include<vector>
#define MAX 501
#define INF 0x0FFFFFFF

using namespace std;

int map[MAX][MAX],cost[MAX][MAX];
int length[MAX],mincost[MAX];
int path[MAX],visited[MAX];

void Init(int n)
{
	int i,j;
	for(i=0;i<n;i++)
	{
		length[i]=mincost[i]=INF;
		for(j=0;j<n;j++)
		{
			map[i][j]=INF;
			cost[i][j]=INF;
		}
	}
}

void Dijkstra(int start,int n,int end)
{
	int i,j,k;
	int min=INF,t_cost;
	for(i=0;i<n;i++)
	{
		if(map[start][i]!=INF)
			length[i]=map[start][i];
		if(cost[start][i]!=INF)
			mincost[i]=cost[start][i];
		path[i]=start;
	}
	length[start]=0;
	mincost[start]=0;
	visited[start]=1;
	for(i=1;i<n;i++)
	{
		min=INF;
		for(j=0;j<n;j++)
		{
			if(!visited[j]&&length[j]<min)
			{
				k=j;
				min=length[j];
				t_cost=mincost[j];
			}
		}
		visited[k]=1;
		for(j=0;j<n;j++)
		{
			if(!visited[j]&&length[j]>map[k][j]+min)
			{
				length[j]=map[j][k]+min;
				mincost[j]=cost[j][k]+t_cost;
				path[j]=k;
			}
			else if(!visited[j]&&length[j]==map[k][j]+min
				&&mincost[j]>t_cost+cost[k][j])
			{
				length[j]=map[k][j]+min;
				mincost[j]=cost[k][j]+t_cost;
				path[j]=k;
			}
		}
	}                        //path[]中存储的是前驱节点,path[i]=k;
	int stack[MAX],top=-1;  //表示进过节点k到达i
	int index=end;
	while(index!=start)
	{
		stack[++top]=index;
		index=path[index];
	}
	printf("%d",start);
	while(top>-1)
	{
		printf(" %d",stack[top]);
		top--;
	}
	printf(" %d %d\n",length[end],mincost[end]);
}

int main(int argc,char *argv[])
{
	int n,m,s,d;
	int i;
	scanf("%d%d%d%d",&n,&m,&s,&d);
    Init(n);
	for(i=0;i<m;i++)
	{
		int a,b,l,c;
		scanf("%d%d%d%d",&a,&b,&l,&c);
		if(map[a][b]>l||(map[a][b]==l&&cost[a][b]>c))//取重复路径中短的和花费
		{                                            //少的
			map[a][b]=map[b][a]=l;
		  	cost[a][b]=cost[b][a]=c;
		}
	}
	Dijkstra(s,n,d);
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值