Pat(Advanced Level)Practice--1017(Queueing at Bank)

Pat1017代码

题目描述:

Suppose a bank has K windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. All the customers have to wait in line behind the yellow line, until it is his/her turn to be served and there is a window available. It is assumed that no window can be occupied by a single customer for more than 1 hour.

Now given the arriving time T and the processing time P of each customer, you are supposed to tell the average waiting time of all the customers.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10000) - the total number of customers, and K (<=100) - the number of windows. Then N lines follow, each contains 2 times: HH:MM:SS - the arriving time, and P - the processing time in minutes of a customer. Here HH is in the range [00, 23], MM and SS are both in [00, 59]. It is assumed that no two customers arrives at the same time.

Notice that the bank opens from 08:00 to 17:00. Anyone arrives early will have to wait in line till 08:00, and anyone comes too late (at or after 17:00:01) will not be served nor counted into the average.

Output Specification:

For each test case, print in one line the average waiting time of all the customers, in minutes and accurate up to 1 decimal place.

Sample Input:
7 3
07:55:00 16
17:00:01 2
07:59:59 15
08:01:00 60
08:00:00 30
08:00:02 2
08:03:00 10
Sample Output:
8.2

AC代码:
#include<cstdio>
#include<vector>
#include<algorithm>
#define MAX 105

using namespace std;

typedef struct Customer
{
	int atime;//arrive time
	int ptime;//process time
	int wtime;//waiting time
}Customer;

typedef struct Windows
{
	int begin;//begin service of a customer
	int end;//end service of a customer
}Windows;

bool cmp(const Customer &l,const Customer &r)
{
	return l.atime<r.atime;
}

Windows w[MAX];
vector<Customer> waiting;

int main(int argc,char *argv[])
{
	int n,k;
	int i,j;
	int count=0;
	scanf("%d%d",&n,&k);
	for(i=0;i<n;i++)
	{
		Customer temp;
		int h,m,s,p;
		scanf("%d:%d:%d %d",&h,&m,&s,&p);
		temp.atime=h*3600+m*60+s;
		if(temp.atime>=17*3600+1)//arrive time behind 17:00:01
			continue;
		if(p>60)//service time more than 60 minutes
			p=60;
		temp.ptime=p*60;
		temp.wtime=0;
		waiting.push_back(temp);
	}
	sort(waiting.begin(),waiting.end(),cmp);
	for(i=1;i<=k&&count<waiting.size();i++)//刚开始为k个窗口分配客户
	{	                                   //每个窗口处理一个客户
		if(waiting[count].atime<8*3600)
		{
			waiting[count].wtime=8*3600-waiting[count].atime;
			w[i].begin=8*3600;
			w[i].end=8*3600+waiting[count].ptime;
		}
		else
		{
			w[i].begin=waiting[count].atime;
		    w[i].end=w[i].begin+waiting[count].ptime;
		}
		count++;
	}                          // 将剩余客户依次分给最先空闲的窗口
	while(count<waiting.size())//窗口处于忙碌状态,取最先完成的窗口服务顾客
	{
		int min=1;
		for(i=2;i<=k;i++)
			if(w[i].end<w[min].end)
				min=i;
		if(waiting[count].atime<w[min].end)//窗口不空闲,此时有顾客排队
		{
			waiting[count].wtime+=w[min].end-waiting[count].atime;
		    w[min].begin=w[min].end;
		    w[min].end=w[min].begin+waiting[count].ptime;
		}
		else//窗口空闲,无需等待
		{
			w[min].begin=waiting[count].atime;
			w[min].end=w[min].begin+waiting[count].ptime;
		}
		count++;
	}
	double ans=0;
	for(i=0;i<waiting.size();i++)
		ans+=waiting[i].wtime;
	printf("%.1f\n",ans*1.0/waiting.size()/60);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值