HDOJ 3874 Necklace

树状数组求区间内不同元素和
离线考虑,把询问区间按右端点排序,记录每个数上一次出现的位置,如果已经出现过,把上一个删掉,当前的加进去,即只留下最近的一个元素。

Necklace

Time Limit: 15000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 2485    Accepted Submission(s): 880


Problem Description
Mery has a beautiful necklace. The necklace is made up of N magic balls. Each ball has a beautiful value. The balls with the same beautiful value look the same, so if two or more balls have the same beautiful value, we just count it once. We define the beautiful value of some interval [x,y] as F(x,y). F(x,y) is calculated as the sum of the beautiful value from the xth ball to the yth ball and the same value is ONLY COUNTED ONCE. For example, if the necklace is 1 1 1 2 3 1, we have F(1,3)=1, F(2,4)=3, F(2,6)=6.

Now Mery thinks the necklace is too long. She plans to take some continuous part of the necklace to build a new one. She wants to know each of the beautiful value of M continuous parts of the necklace. She will give you M intervals [L,R] (1<=L<=R<=N) and you must tell her F(L,R) of them.
 

Input
The first line is T(T<=10), representing the number of test cases.
  For each case, the first line is a number N,1 <=N <=50000, indicating the number of the magic balls. The second line contains N non-negative integer numbers not greater 1000000, representing the beautiful value of the N balls. The third line has a number M, 1 <=M <=200000, meaning the nunber of the queries. Each of the next M lines contains L and R, the query.
 

Output
For each query, output a line contains an integer number, representing the result of the query.
 

Sample Input
  
  
2 6 1 2 3 4 3 5 3 1 2 3 5 2 6 6 1 1 1 2 3 5 3 1 1 2 4 3 5
 

Sample Output
  
  
3 7 14 1 3 6
 

Source
 

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>

using namespace std;

typedef long long int LL;

struct ASK
{
    int l,r,id;
}ask[200100];

int n,q;
int pre[1000100];
LL tree[50100],val[50100],ans[200100];

bool cmp(ASK a,ASK b)
{
    if(a.r!=b.r) return a.r<b.r;
    return a.l<b.l;
}

int lowbit(int x)
{
    return x&(-x);
}

void ADD(int p,int v)
{
    for(int i=p;i<=n+10;i+=lowbit(i)) tree[i]+=v;
}

LL SUM(int p)
{
    LL sum=0;
    for(int i=p;i;i-=lowbit(i)) sum+=tree[i];
    return sum;
}

int main()
{
    int TAT;
    scanf("%d",&TAT);
while(TAT--)
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%I64d",&val[i]);
    scanf("%d",&q);
    for(int i=0;i<q;i++)
    {
        scanf("%d%d",&ask[i].l,&ask[i].r);
        ask[i].id=i;
    }

    sort(ask,ask+q,cmp);
    memset(tree,0,sizeof(tree));
    memset(pre,-1,sizeof(pre));

    int cur=1;
    for(int i=0;i<q;i++)
    {
        while(cur<=ask[i].r)
        {
            int x=val[cur];
            if(pre[x]!=-1)
            {
                ADD(pre[x],-x);
            }
            ADD(cur,x);
            pre[x]=cur++;
        }
        ans[ask[i].id]=SUM(ask[i].r)-SUM(ask[i].l-1);
    }
    for(int i=0;i<q;i++)
        printf("%I64d\n",ans[i]);
}
    return 0;
}





  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值