HDOJ 4293 Groups


水DP。。。

Groups

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1133    Accepted Submission(s): 440


Problem Description
  After the regional contest, all the ACMers are walking alone a very long avenue to the dining hall in groups. Groups can vary in size for kinds of reasons, which means, several players could walk together, forming a group.
  As the leader of the volunteers, you want to know where each player is. So you call every player on the road, and get the reply like “Well, there are A i players in front of our group, as well as B i players are following us.” from the i th player.
  You may assume that only N players walk in their way, and you get N information, one from each player.
  When you collected all the information, you found that you’re provided with wrong information. You would like to figure out, in the best situation, the number of people who provide correct information. By saying “the best situation” we mean as many people as possible are providing correct information.
 

Input
  There’re several test cases.
  In each test case, the first line contains a single integer N (1 <= N <= 500) denoting the number of players along the avenue. The following N lines specify the players. Each of them contains two integers A i and B i (0 <= A i,B i < N) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case your program should output a single integer M, the maximum number of players providing correct information.
 

Sample Input
  
  
3 2 0 0 2 2 2 3 2 0 0 2 2 2
 

Sample Output
  
  
2 2
Hint
The third player must be making a mistake, since only 3 plays exist.
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

int n,dp[550],p[550][550];

int main()
{
	while(scanf("%d",&n)!=EOF)	
	{
		int a,b;
		memset(dp,0,sizeof(dp));
		memset(p,0,sizeof(p));
		for(int i=0;i<n;i++) 
		{
			scanf("%d%d",&a,&b);
			int st=a+1,ed=n-b;
			p[st][ed]=min(p[st][ed]+1,ed-st+1);
		}
		for(int i=1;i<=n;i++)
		{
			for(int j=0;j<i;j++)
			{
				dp[i]=max(dp[i],dp[j]+p[j+1][i]);
			}
		}
		printf("%d\n",dp[n]);
	}
	return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值