Uva 11346 Probability 积分


化成反比函数求积分


G - Probability

Time Limit: 1 sec 
Memory Limit: 16MB

Consider rectangular coordinate system and point L(X,Y) which is randomly chosen among all points in the area A which is defined in the following manner: A = {(x,y) | x is from interval [-a;a]; y is from interval [-b;b]}. What is the probability P that the area of a rectangle that is defined by points (0,0) and (X,Y) will be greater than S?

INPUT:
The number of tests N <= 200 is given on the first line of input. Then N lines with one test case on each line follow. The test consists of 3 real numbers a > 0, b > 0 ir S => 0.

OUTPUT:
For each test case you should output one number P and percentage "  %" symbol following that number on a single line. P must be rounded to 6 digits after decimal point.

SAMPLE INPUT:
3
10 5 20
1 1 1
2 2 0

SAMPLE OUTPUT:

 23.348371%
0.000000%
100.000000%

Problem setters: Aleksej Viktorchik, Leonid Shishlo. 
Huge Easy Contest #1




/* ***********************************************
Author        :CKboss
Created Time  :2015年01月29日 星期四 22时10分37秒
File Name     :UVA11346.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

double a,b,s;

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%lf%lf%lf",&a,&b,&s);
		if(s==0)
		{
			printf("100.000000%\n");
			continue;
		}
		else if(a*b<=s)
		{
			printf("0.000000%\n");
			continue;
		}
		double area = log(b)-log(s/a);
		double mu = 4*a*b;
		area = s + s*area;
		area*=4;
		printf("%.6lf%\n",100.*(1.-area/mu));
	}
    
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值