HDOJ 5184 Brackets 卡特兰数扩展


既求从点(0,0)只能向上或者向右并且不穿越y=x到达点(a,b)有多少总走法...

公式: C(a+b,min(a,b))-C(a+b,min(a,b)-1)  /// 

折纸法证明卡特兰数: http://blog.sina.com.cn/s/blog_6917f47301010cno.html


Brackets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 506    Accepted Submission(s): 120


Problem Description
We give the following inductive definition of a “regular brackets” sequence:
● the empty sequence is a regular brackets sequence,
● if s is a regular brackets sequence, then (s) are regular brackets sequences, and
● if a and b are regular brackets sequences, then ab is a regular brackets sequence.
● no other sequence is a regular brackets sequence

For instance, all of the following character sequences are regular brackets sequences:
(), (()), ()(), ()(())
while the following character sequences are not:
(, ), )(, ((), ((()

Now we want to construct a regular brackets sequence of length  n , how many regular brackets sequences we can get when the front several brackets are given already.
 

Input
Multi test cases (about  2000 ), every case occupies two lines.
The first line contains an integer  n .
Then second line contains a string str which indicates the front several brackets.

Please process to the end of file.

[Technical Specification]
1n1000000
str contains only '(' and ')' and length of str is larger than 0 and no more than  n .
 

Output
For each case,output answer %  1000000007  in a single line.
 

Sample Input
  
  
4 () 4 ( 6 ()
 

Sample Output
  
  
1 2 2
Hint
For the first case the only regular sequence is ()(). For the second case regular sequences are (()) and ()(). For the third case regular sequences are ()()() and ()(()).
 



/* ***********************************************
Author        :CKboss
Created Time  :2015年03月18日 星期三 20时10分21秒
File Name     :HDOJ5184.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

const int maxn=1001000;
const LL mod=1000000007LL;

int n,len;
char str[maxn];

LL inv[maxn];
LL jc[maxn],jcv[maxn];

void init()
{
	inv[1]=1; jc[0]=1; jcv[0]=1;
	jc[1]=1; jcv[1]=1;

	for(int i=2;i<maxn;i++)
	{
		inv[i]=inv[mod%i]*(mod-mod/i)%mod;
		jc[i]=(jc[i-1]*i)%mod;
		jcv[i]=(jcv[i-1]*inv[i])%mod;
	}
}

LL COMB(LL n,LL m)
{
	if(m<0||m>n) return 0LL;
	if(m==0||m==n) return 1LL;
	LL ret=((jc[n]*jcv[n-m])%mod*jcv[m])%mod;
	return ret;
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);

	init();
	while(scanf("%d",&n)!=EOF)
	{
		scanf("%s",str);
		len=strlen(str);

		bool flag=true;
		if(n%2==1) flag=false;
		int left=0,right=0;
		for(int i=0;i<len&&flag;i++)
		{
			if(str[i]=='(') left++;
			else if(str[i]==')') right++;
			if(left>=right) continue;
			else flag=false;
		}
		if(flag==false) { puts("0"); continue; }

		int a=n/2-left; /// remain left
		int b=n/2-right; /// remain right

		if(b>a) swap(a,b);
		LL ans = (COMB(a+b,b)-COMB(a+b,b-1)+mod)%mod;
		cout<<ans<<endl;
	}
    
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值