HDOJ 5276 YJC tricks time multimap


multimap的使用

YJC tricks time

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/262144 K (Java/Others)
Total Submission(s): 492    Accepted Submission(s): 215


Problem Description
YJC received a mysterious present. It's a clock and it looks like this. 



YJC is not a timelord so he can't trick time but the clock is so hard to read. So he'd like to trick you.

Now YJC gives you the angle between the hour hand and the minute hand, you'll tell him what time it is now.

You'll give him the possible time in the format:

HH:MM:SS

HH represents hour, MM represents minute, SS represents second.
(For example,  08:30:20 )

We use twelve hour system, which means the time range is from  00:00:00  to  11:59:59 .

Also, YJC doesn't want to be too accurate, one answer is considered acceptable if and only if SS mod 10 = 0 .
 

Input
Multiple tests.There will be no more than  1000  cases in one test.
for each case:

One integer  x  indicating the angle, for convenience,  x  has been multiplied by  12000 . (So you can read it as integer not float) In this case we use degree as the unit of the angle, and it's an inferior angle. Therefore,  x  will not exceed  12000180=2160000 .
 

Output
For each case:

T  lines.  T  represents the total number of answers of this case.

Output the possible answers in ascending order. (If you cannot find a legal answer, don't output anything in this case)
 

Sample Input
  
  
99000 0
 

Sample Output
  
  
00:01:30 11:58:30 00:00:00
 

Source
 

/* ***********************************************
Author        :CKboss
Created Time  :2015年07月10日 星期五 08时55分44秒
File Name     :HDOJ5276.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

struct Time
{
	int hh,mm,ss;
};

multimap<int,Time> mt;

/// every 10 second
/// s: 720000 m: 12000 h: 1000

const int DS=720000;
const int DM=12000;
const int DH=1000;
const int MOD=360*12000;

int degS=-DS,degM=-DM,degH=-DH;

int ADD()
{
	degS=(degS+DS)%MOD;
	degM=(degM+DM)%MOD;
	degH=(degH+DH)%MOD;

	int dur=abs(degM-degH);
	if(dur>MOD/2) dur=MOD-dur;

	return dur;
}

void init()
{
	for(int h=0;h<=11;h++)
	{
		for(int m=0;m<=59;m++)
		{
			for(int s=0;s<60;s+=10)
			{
				int t=ADD();
				mt.insert(make_pair(t,(Time){h,m,s}));
			}
		}
	}
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	init();
	int x;
	while(scanf("%d",&x)!=EOF)
	{
		multimap<int,Time>::iterator it;
		it=mt.find(x);
		int cnt=mt.count(x);
		for(int i=0;i<cnt;i++,it++)
		{
			Time time = it->second;
			printf("%02d:%02d:%02d\n",time.hh,time.mm,time.ss);
		}
	}
    
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值