HDOJ 5411 CRB and Puzzle 矩阵快速幂


直接构造矩阵,最上面一行加一排1.快速幂计算矩阵的m次方,统计第一行的和

CRB and Puzzle

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 133    Accepted Submission(s): 63


Problem Description
CRB is now playing Jigsaw Puzzle.
There are  N  kinds of pieces with infinite supply.
He can assemble one piece to the right side of the previously assembled one.
For each kind of pieces, only restricted kinds can be assembled with.
How many different patterns he can assemble with at most  M  pieces? (Two patterns  P  and  Q  are considered different if their lengths are different or there exists an integer  j  such that  j -th piece of  P  is different from corresponding piece of  Q .)
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:
The first line contains two integers  N M  denoting the number of kinds of pieces and the maximum number of moves.
Then  N  lines follow.  i -th line is described as following format.
a1 a2 ... ak
Here  k  is the number of kinds which can be assembled to the right of the  i -th kind. Next  k  integers represent each of them.
1 ≤  T  ≤ 20
1 ≤  N  ≤ 50
1 ≤  M  ≤  105
0 ≤  k  ≤  N
1 ≤  a1  <  a2  < … <  ak  ≤ N

 

Output
For each test case, output a single integer - number of different patterns modulo 2015.
 

Sample Input
  
  
1 3 2 1 2 1 3 0
 

Sample Output
  
  
6
Hint
possible patterns are ∅, 1, 2, 3, 1→2, 2→3
 

Author
KUT(DPRK)
 

Source
 




/* ***********************************************
Author        :CKboss
Created Time  :2015年08月20日 星期四 23时25分19秒
File Name     :HDOJ5411.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

const int mod=2015;

int n,m;

struct Matrix
{
	int m[60][60];
	Matrix() { memset(m,0,sizeof(m)); }
	void getE()
	{
		for(int i=0;i<n;i++) m[i][i]=1;
	}
	void toString()
	{
		for(int i=0;i<n;i++)
		{
			for(int j=0;j<n;j++)
			{
				printf("%d,",m[i][j]);
			}
			putchar(10);
		}
	}
};

Matrix Mulit(Matrix a,Matrix b)
{
	Matrix M;
	for(int i=0;i<n;i++)
	{
		for(int j=0;j<n;j++)
		{
			int temp=0;
			for(int k=0;k<n;k++)
			{
				temp=(temp+a.m[i][k]*b.m[k][j])%mod;
			}
			M.m[i][j]=temp;
		}
	}
	return M;
}

Matrix QuickPow(Matrix a,int x)
{
	Matrix e;
	e.getE();
	while(x)
	{
		if(x&1) e=Mulit(e,a);
		a=Mulit(a,a);
		x/=2;
	}
	return e;
}

int main()
{
	//freopen("in.txt","r",stdin);
	//freopen("out.txt","w",stdout);

	int T_T;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d%d",&n,&m);
		Matrix M;
		for(int i=1;i<=n;i++)
		{
			int k,x;
			scanf("%d",&k);
			for(int j=0;j<k;j++)
			{
				scanf("%d",&x);
				M.m[i][x]=1;
			}
		}
		n++;
		for(int i=0;i<n;i++) M.m[0][i]=1;
		Matrix mt=QuickPow(M,m);
		int ans=0;
		for(int i=0;i<n;i++)
		{
			ans=(ans+mt.m[0][i])%mod;
		}
		printf("%d\n",ans);
	}
    
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值