HDOJ 4454 Stealing a Cake 计算几何


暴力枚举角度.....

Stealing a Cake

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2495    Accepted Submission(s): 681


Problem Description
There is a big round cake on the ground. A small ant plans to steal a small piece of cake. He starts from a certain point, reaches the cake, and then carry the piece back home. He does not want to be detected, so he is going to design a shortest path to achieve his goal. 

The big cake can be considered as a circle on a 2D plane. The ant’s home can be considered as a rectangle. The ant can walk through the cake. Please find out the shortest path for the poor ant.
 

Input
The input consists of several test cases.
The first line of each test case contains x,y, representing the coordinate of the starting point. The second line contains x, y, r. The center of the cake is point (x,y) and the radius of the cake is r. The third line contains x1,y1,x2,y2, representing the coordinates of two opposite vertices of the rectangle --- the ant's home.
All numbers in the input are real numbers range from -10000 to 10000. It is guaranteed that the cake and the ant's home don't overlap or contact, and the ant's starting point also is not inside the cake or his home, and doesn't contact with the cake or his home.
If the ant touches any part of home, then he is at home.
Input ends with a line of 0 0. There may be a blank line between two test cases.
 

Output
For each test case, print the shortest distance to achieve his goal. Please round the result to 2 digits after decimal point.
 

Sample Input
  
  
1 1 -1 1 1 0 -1 1 0 0 2 -1 1 1 0 -1 1 0 0 0
 

Sample Output
  
  
1.75 2.00
 

Source
 



#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;

const double eps=1e-6;

int dcmp(double x)
{
    if(fabs(x)<eps) return 0;
    return (x<0)?-1:1;
}

struct Point
{
    double x,y;
    Point(double _x=0,double _y=0){x=_x; y=_y;}
};

Point operator+(Point A,Point B){return Point(A.x+B.x,A.y+B.y);}
Point operator-(Point A,Point B){return Point(A.x-B.x,A.y-B.y);}
bool operator==(const Point& a,const Point& b ){return dcmp(a.x-b.x)==0&&dcmp(a.y-b.y)==0;}

double Cross(Point A,Point B){return A.x*B.y-A.y*B.x;}
double Dot(Point A,Point B){return A.x*B.x+A.y*B.y;}
double Length(Point A){return sqrt(Dot(A,A));}

double DistanceToSegment(Point P,Point A,Point B)
{
    if(A==B) return Length(P-A);
    Point v1=B-A,v2=P-A,v3=P-B;
    if(dcmp(Dot(v1,v2))<0) return Length(v2);
    else if(dcmp(Dot(v1,v3))>0) return Length(v3);
    else return fabs(Cross(v1,v2))/Length(v1);
}

const double pi=acos(-1.0);

struct Circle
{
    Point c;
    double r;
    Circle(Point _c=0,double _r=0):c(_c),r(_r){}
    Point point(double a)
    {
        return Point(c.x+cos(a)*r,c.y+sin(a)*r);
    }
};

double a,b,c,d;

Point P1;
Point L[4];
Circle C;

int main()
{
    while(scanf("%lf%lf",&a,&b)!=EOF)
    {
        if(dcmp(a)==0&&dcmp(b)==0) break;

        P1=Point(a,b);
        scanf("%lf%lf%lf",&a,&b,&c);
        C=Circle(Point(a,b),c);
        scanf("%lf%lf%lf%lf",&a,&b,&c,&d);
        if(a>c) swap(a,c);
        if(b>d) swap(b,d);
        L[0]=Point(a,b); L[1]=Point(a,d);
        L[2]=Point(c,d); L[3]=Point(c,b);

        double delta=2.0*pi*0.0001;
        double ans=1e30;

        for(int i=0;i<10000;i++)
        {
			double du=delta*i;
            Point p = Point(C.c.x+cos(du)*C.r,C.c.y+sin(du)*C.r);

            double Part1=DistanceToSegment(p,L[3],L[0]);
			for(int i=0;i<3;i++)
			{
				double temp = DistanceToSegment(p,L[i],L[i+1]);
				Part1=min(Part1,temp);
			}
			double Part2=Length(p-P1);

            ans=min(ans,Part1+Part2);
        }
        printf("%.2lf\n",ans);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值