HDOJ 4359 Easy Tree DP? DP



Easy Tree DP?

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1482    Accepted Submission(s): 565


Problem Description
A Bear tree is a binary tree with such properties : each node has a value of 2 0,2 1…2 (N-1)(each number used only once),and for each node ,its left subtree’s elements’ sum<its right subtree’s elements’ sum(if the node hasn’t left/right subtree ,this limitation is invalid).
You need to calculate how many Bear trees with N nodes and exactly D deeps.
 

Input
First a integer T(T<=5000),then T lines follow ,every line has two positive integer N,D.(1<=D<=N<=360).
 

Output
For each test case, print "Case #t:" first, in which t is the number of the test case starting from 1 and the number of Bear tree.(mod 10 9+7)
 

Sample Input
  
  
2 2 2 4 3
 

Sample Output
  
  
Case #1: 4 Case #2: 72
 

Author
smxrwzdx@UESTC_Brightroar
 

Source
 


/* ***********************************************
Author        :CKboss
Created Time  :2015年09月04日 星期五 16时40分18秒
File Name     :1009.cpp
************************************************ */

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <string>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>

using namespace std;

typedef long long int LL;

const int maxn=400;
const LL mod=1e9+7;

LL dp[maxn][maxn];
LL C[maxn][maxn];

void init()
{
	for(int i=1;i<maxn;i++) C[i][0]=C[i][i]=1LL;
	for(int i=1;i<maxn;i++)
	{
		for(int j=1;j<i;j++)
		{
			C[i][j]=(C[i-1][j]+C[i-1][j-1])%mod;
		}
	}

	for(int i=1;i<=360;i++) dp[1][i]=1;
	for(int i=2;i<=360;i++) dp[2][i]=4;

	for(int i=3;i<=360;i++)
	{
		for(int j=1;j<=360;j++)
		{
			dp[i][j]=(dp[i][j]+dp[i-1][j-1]*2*i)%mod;
			for(int left=1;left<=i-2;left++)
			{
				int right=i-1-left;
				dp[i][j]=(dp[i][j]+dp[left][j-1]*dp[right][j-1]%mod*i%mod*C[i-2][left]%mod)%mod;
			}
		}
	}
}

int main()
{
    //freopen("in.txt","r",stdin);
    //freopen("out.txt","w",stdout);
    
	init();
	int T_T,cas=1,n,d;
	scanf("%d",&T_T);
	while(T_T--)
	{
		scanf("%d%d",&n,&d);
		printf("Case #%d: %lld\n",cas++,(dp[n][d]-dp[n][d-1]+mod)%mod);
	}
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
信息数据从传统到当代,是一直在变革当中,突如其来的互联网让传统的信息管理看到了革命性的曙光,因为传统信息管理从时效性,还是安全性,还是可操作性等各个方面来讲,遇到了互联网时代才发现能补上自古以来的短板,有效的提升管理的效率和业务水平。传统的管理模式,时间越久管理的内容越多,也需要更多的人来对数据进行整理,并且数据的汇总查询方面效率也是极其的低下,并且数据安全方面永远不会保证安全性能。结合数据内容管理的种种缺点,在互联网时代都可以得到有效的补充。结合先进的互联网技术,开发符合需求的软件,让数据内容管理不管是从录入的及时性,查看的及时性还是汇总分析的及时性,都能让正确率达到最高,管理更加的科学和便捷。本次开发的高校科研信息管理系统实现了操作日志管理、字典管理、反馈管理、公告管理、科研成果管理、科研项目管理、通知管理、学术活动管理、学院部门管理、科研人员管理、管理员管理等功能。系统用到了关系型数据库中王者MySql作为系统的数据库,有效的对数据进行安全的存储,有效的备份,对数据可靠性方面得到了保证。并且程序也具备程序需求的所有功能,使得操作性还是安全性都大大提高,让高校科研信息管理系统更能从理念走到现实,确确实实的让人们提升信息处理效率。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值