UVa439 Knight Moves

Time Limit: 3000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

Description

Download as PDF

A friend of you is doing research on the Traveling Knight Problem (TKP) where you are to find the shortest closed tour of knight moves that visits each square of a given set of n squares on a chessboard exactly once. He thinks that the most difficult part of the problem is determining the smallest number of knight moves between two given squares and that, once you have accomplished this, finding the tour would be easy.

Of course you know that it is vice versa. So you offer him to write a program that solves the "difficult" part.

Your job is to write a program that takes two squares a and b as input and then determines the number of knight moves on a shortest route from a to b.

Input Specification

The input file will contain one or more test cases. Each test case consists of one line containing two squares separated by one space. A square is a string consisting of a letter (a-h) representing the column and a digit (1-8) representing the row on the chessboard.

Output Specification

For each test case, print one line saying "To get from xx to yy takes n knight moves.".

Sample Input

e2 e4
a1 b2
b2 c3
a1 h8
a1 h7
h8 a1
b1 c3
f6 f6

Sample Output

To get from e2 to e4 takes 2 knight moves.
To get from a1 to b2 takes 4 knight moves.
To get from b2 to c3 takes 2 knight moves.
To get from a1 to h8 takes 6 knight moves.
To get from a1 to h7 takes 5 knight moves.
To get from h8 to a1 takes 6 knight moves.
To get from b1 to c3 takes 1 knight moves.
To get from f6 to f6 takes 0 knight moves.

分析:

其实就是图的BFS。嗯。

代码:

// #define _CRT_SECURE_NO_WARNINGS
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct Node{
	int x, y;
	int dpt;
	Node(int a, int b, int depth) :x(a), y(b), dpt(depth) {}
};

const int maxn = 8;

int chess[maxn][maxn];
int sx, sy, ex, ey;

bool check(int x, int y) {
	if (x < 0 || x >= 8 || y < 0 || y >= 8) return false;
	return true;
}

int bfs(int x, int y) {
	queue<Node> q;
	q.push(Node(x, y, 0));
	int dpt = 0;
	while (!q.empty()) {
		Node u = q.front(); q.pop();
		chess[u.x][u.y] = 1;
		// printf("(%d,%d)\n", u.x, u.y);
		if (u.x == ex && u.y == ey) { dpt = u.dpt; break; }
		for (int d1 = -2; d1 <= 2; d1 += 4)
			for (int d2 = -1; d2 <= 1; d2 += 2) {
                if (check(u.x + d1, u.y + d2) && !chess[u.x + d1][u.y + d2]) {
                    q.push(Node(u.x + d1, u.y + d2, u.dpt + 1));
                    chess[u.x + d1][u.y + d2] = 1;
                }
                if (check(u.x + d2, u.y + d1) && !chess[u.x + d2][u.y + d1]) {
                    q.push(Node(u.x + d2, u.y + d1, u.dpt + 1));
                    chess[u.x + d2][u.y + d1] = 1;
                }
			}

	}
	return dpt;
}

int main() {
	char start[3], end[3], s[5];
	while (gets(s)) {
        start[0] = s[0]; start[1] = s[1]; start[2] = '\0';            // 这里出现了有意思的事情,数组需要多开一位,不然start读入出错(?)
        end[0] = s[3]; end[1] = s[4]; end[2] = '\0';                  // 在codeblocks中出现上述情况,而在VS中运行良好
		// printf("start:%c%c---end:%s\n", start[0], start[1], end);
		sx = start[0] - 'a'; sy = start[1] - '1';
		ex = end[0] - 'a'; ey = end[1] - '1';
		// printf("s(%d,%d), e(%d,%d)\n", sx, sy, ex, ey);
		memset(chess, 0, sizeof(chess));
		printf("To get from %s to %s takes %d knight moves.\n", start, end, bfs(sx, sy));
	}
	return 0;
}

VS版本:

#define _CRT_SECURE_NO_WARNINGS    // 防止VS报错
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;

struct Node{
	int x, y;
	int dpt;
	Node(int a, int b, int depth) :x(a), y(b), dpt(depth) {}
};

const int maxn = 8;

int chess[maxn][maxn];
int sx, sy, ex, ey;

bool check(int x, int y) {
	if (x < 0 || x >= 8 || y < 0 || y >= 8) return false;
	return true;
}

int bfs(int x, int y) {
	queue<Node> q;
	q.push(Node(x, y, 0));
	int dpt = 0;
	while (!q.empty()) {
		Node u = q.front(); q.pop();
		chess[u.x][u.y] = 1;
		if (u.x == ex && u.y == ey) { dpt = u.dpt; break; }
		for (int d1 = -2; d1 <= 2; d1 += 4)
			for (int d2 = -1; d2 <= 1; d2 += 2) {
			if (check(u.x + d1, u.y + d2) && !chess[u.x + d1][u.y + d2]) {
				q.push(Node(u.x + d1, u.y + d2, u.dpt + 1));
				chess[u.x + d1][u.y + d2] = 1;
			}
			if (check(u.x + d2, u.y + d1) && !chess[u.x + d2][u.y + d1]) {
				q.push(Node(u.x + d2, u.y + d1, u.dpt + 1));
				chess[u.x + d2][u.y + d1] = 1;
			}
			}

	}
	return dpt;
}

int main() {
	char start[2], end[2];
	while (~scanf("%s", start)) {                   // 这样在codeblocks中出现问题
		scanf("%s", end);
		sx = start[0] - 'a'; sy = start[1] - '1';
		ex = end[0] - 'a'; ey = end[1] - '1';
		memset(chess, 0, sizeof(chess));
		printf("To get from %s to %s takes %d knight moves.\n", start, end, bfs(sx, sy));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值