HLG 1597(最长飞递增子序列)

链接:http://acm.hrbust.edu.cn/index.php?m=ProblemSet&a=showProblem&problem_id=1597

题意:

Description
给一个长度为n的整数序列A0,A1,......An-1,找出最长的非递增子序列的长度
Input

输入第一行为数据组数T(T<=20)。

每组数据的第一行为整数的个数n(2<=n<=1000),第二行为n个绝对值不超过150000的整数。

Output
对于每组数据,输出最长的非递增子序列的长度。
Sample Input
2
3
1 1 3
4
-1 4 3 2
Sample Output
2
3
解析:

这类都是属于序列问题,不过常见的就是最长单调子序列,这里只是换了一下,不过方法都还是一样的;


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#define MAXN 1000+10

int a[MAXN], x[MAXN];

int main()
{
    int n, cas;
    scanf("%d", &cas);

    while(cas--){
        memset(x, 0, sizeof(x));
        scanf("%d", &n);
        for(int i=0; i<n; i++) scanf("%d", &a[i]);
        for(int i=0; i<n; i++) x[i] = 1;
        int max = 1;
        for(int i=1; i<n; i++) {
            for(int j=i-1; j>=0; j--) {
                if(a[j] >= a[i]) {
                    if(x[j]+1 > x[i]) x[i] = x[j]+1;
                }
            }
            if(max < x[i]) max = x[i];
        }
        printf("%d\n", max);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值