HDU 1671 Trie树【 动态分配内存 + 内存释放 】

Phone List

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9575    Accepted Submission(s): 3253


Problem Description
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
1. Emergency 911
2. Alice 97 625 999
3. Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
 

Input
The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input
  
  
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output
  
  
NO YES
 



之 所以想写此题的题解,就是想给自己一个警醒,动态内存,有分配就应该要有释放。


解析见代码:

#include <iostream>
#include <cstdio>
using namespace std;

const int maxx = 10;
char str[10000][10];

struct node
{
    int count; ///记录该节点被访问的次数
    node *next[maxx];
    node( ) ///使用New时自动调用,对NODE进行初始化
    {
        count = 1;
        for(int i = 0;i < maxx; i++)
        {
            next[i] = NULL;
        }
    }
};

void insert(node *&root,char *str)
{
    node *l=root;
    int i=0,branch;
    while(str[i]!='\0')
    {
        branch=str[i]-'0';
        if(l->next[branch])
        {
            l->next[branch]->count++;
        }
        else
        {
            l->next[branch]=new node; ///动态分配内存
        }
        l=l->next[branch];
        i++;
    }
}

int search(node *&root,char *str)
{
    node *l=root;
    int i=0,branch,sum;
    while(str[i]!='\0')
    {
        branch=str[i]-'0'; ///把字符型数字转换为整型数字
        if(l->next[branch])
        {
            l=l->next[branch];
            sum=l->count;
        }
        else return 0;
        i++;
    }
    return sum;
}

void del(node *p)  ///释放内存的函数
{
    int i=0;
    for(;i < 10;i ++)
    {
        if(p->next[i]!=NULL)  ///假如下一个节点不是NULL则继续寻找下一个节点的空节点
        {
            del(p->next[i]);
        }
    }
    delete p;
}

int main( )
{
    int n,t;
    cin>>t;
    while(t--)
    {
        node *root= new node; ///分配内存
        cin>>n;
        getchar( );
        for(int o=1;o <= n; o++)
        {
            gets(str[o]);
            insert(root,str[o]);
        }
        int judge = 0;
        for(int i=1; i<= n; i++)
        {
            if(search(root,str[i])>1)  ///一旦出现有相同前缀的字符串,则不必继续寻找
            {
                judge=1;
                break;
            }
        }
        if(judge)
        {
            cout<<"NO"<<endl;
        }
        else
        {
            cout<<"YES"<<endl;
        }
        del(root);  ///释放内存
    }
    return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值