poj 1144 Network 图的割顶判断模板

Network
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 8797 Accepted: 4116

Description

A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is 
possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure 
occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.

Input

The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated 
by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;

Output

The output contains for each block except the last in the input file one line containing the number of critical places.

Sample Input

5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output

1
2

Hint

You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.

//题意,给一个图,求图中割顶的个数~~~


#include "stdio.h"  //poj 1144 割顶的判断模板
#include "vector"
#include "string.h"
using namespace std;

#define N 105
vector<int> a[N];
int root;
int low[N],dfn[N];
bool visit[N],mark[N];
int MIN(int x,int y) { return x<y?x:y; }

void DFS(int x,int times)
{
    int i;
    int count = 0;
    visit[x] = true;
    low[x] = dfn[x] = times;
    for(i=0; i<a[x].size(); ++i)
    {
        int y = a[x][i];
        if(!visit[y])
        {
            count++;
            DFS(y,times+1);
            low[x] = MIN(low[x],low[y]);
            if(x==root && count==2) mark[root] = true; //如果x为根节点,并且子树有两个或两个以上,则为割顶!
            if(x!=root && low[y]>=dfn[x]) mark[x] = true; //如果x的子树中没有节点连接x的祖先(有的话low[x]会变小),则为割顶!
        }
        else
            low[x] = MIN(low[x],dfn[y]);//更新low[x]的值!
    }
}

int main()
{
    int n;
    int i,j;
    char ch;
    while(scanf("%d",&n),n!=0)
    {
        int x,y;
        for(i=0; i<N; ++i)
            a[i].clear();
        while(scanf("%d",&x),x!=0)
        {
            while(scanf("%c",&ch) && ch==' ')
            {
                scanf("%d",&y);
                a[y].push_back(x);
                a[x].push_back(y);
            }
        }
        root = 1;
        int times = 1;
        memset(mark,false,sizeof(mark));  //标记点是否是割顶
        memset(visit,false,sizeof(visit));  //标记点是否已访问
        
        DFS(root,times);
        int ans = 0;
        for(i=1; i<=n; ++i)
        {
            if(mark[i]) ans++; //统计割顶个数
        }
        printf("%d\n",ans);
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值