HDU1701 ACMer 【浮点数误差】

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3536    Accepted Submission(s): 1629


Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

Output
For each test case, output the minumal number of students in HDU.
 

Sample Input
  
  
1 13.00 14.10
 

Sample Output
  
  
15

这题应该分类到“经典题”还是“烂题”呢?这个真的不好说,WA了2次。精度问题,精度问题。。

AC代码:

#include <stdio.h>

int main(){
	int n, m; double a, b;
	scanf("%d", &n);
	while(n--){
		scanf("%lf%lf", &a, &b);
		m = 1;
		while((int)(m * a / 100) >= (int)(m * b / 100)) ++m;
		printf("%d\n", m);
	}
	return 0;
}
WA代码:

#include <stdio.h>

int main(){
	int n, m; double a, b;
	scanf("%d", &n);
	while(n--){
		scanf("%lf%lf", &a, &b);
		a /= 100; b /= 100;
		m = 1;
		while((int)(m * a) >= (int)(m * b)) ++m;
		printf("%d\n", m);
	}
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值