HDU1709 The Balance 【母函数】

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5463    Accepted Submission(s): 2214


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5

题意:给定n个砝码的重量,总质量为sum,问在1~sum中有多少个重量不能被称出来。

题解:母函数的应用,需要注意sum的值。

版本一:171ms

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define maxn 10002

int arr[102], store[maxn];
bool c1[maxn], c2[maxn];

int main()
{
    int n, i, j, k, sum, count;
    while(scanf("%d", &n) != EOF){
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        for(i = sum = 0; i < n; ++i){
            scanf("%d", arr + i);
            sum += arr[i];
        }
        c1[0] = c1[arr[0]] = 1;
        for(i = 1; i < n; ++i){
            for(j = 0; j <= sum; ++j)
                for(k = 0; k <= arr[i] && j + k <= sum; k += arr[i]){
                    c2[k + j] += c1[j];
                    c2[abs(k - j)] += c1[j];
                }
            for(k = 0; k <= sum; ++k){
                c1[k] = c2[k]; c2[k] = 0;
            }
        }
        for(count = 0, i = 1; i <= sum; ++i){
            if(!c1[i]) store[count++] = i;
        }
        printf("%d\n", count);
        if(count) 
            for(i = 0; i < count; ++i)
                if(i != count - 1) printf("%d ", store[i]);
                else printf("%d\n", store[i]);
    }
    return 0;
}

版本二:78ms

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#define maxn 10002

int arr[102], store[maxn];
bool c1[maxn], c2[maxn];

int main()
{
    int n, i, j, k, sum, count;
    while(scanf("%d", &n) != EOF){
        memset(c1, 0, sizeof(c1));
        memset(c2, 0, sizeof(c2));
        for(i = sum = 0; i < n; ++i)
            scanf("%d", arr + i);
        c1[0] = c1[sum = arr[0]] = 1;
        for(i = 1; i < n; ++i){
            for(j = 0; j <= sum; ++j)
                for(k = 0; k <= arr[i]; k += arr[i]){
                    c2[k + j] += c1[j];
                    c2[abs(k - j)] += c1[j];
                }
            sum += arr[i];
            for(k = 0; k <= sum; ++k){
                c1[k] = c2[k]; c2[k] = 0;
            }
        }
        for(count = 0, i = 1; i <= sum; ++i){
            if(!c1[i]) store[count++] = i;
        }
        printf("%d\n", count);
        if(count) 
            for(i = 0; i < count; ++i)
                if(i != count - 1) printf("%d ", store[i]);
                else printf("%d\n", store[i]);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值