HDU4009 Transfer water 【最小树形图】

Transfer water

Time Limit: 5000/3000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 3775    Accepted Submission(s): 1356


Problem Description
XiaoA lives in a village. Last year flood rained the village. So they decide to move the whole village to the mountain nearby this year. There is no spring in the mountain, so each household could only dig a well or build a water line from other household. If the household decide to dig a well, the money for the well is the height of their house multiplies X dollar per meter. If the household decide to build a water line from other household, and if the height of which supply water is not lower than the one which get water, the money of one water line is the Manhattan distance of the two households multiplies Y dollar per meter. Or if the height of which supply water is lower than the one which get water, a water pump is needed except the water line. Z dollar should be paid for one water pump. In addition,therelation of the households must be considered. Some households may do not allow some other households build a water line from there house. Now given the 3‐dimensional position (a, b, c) of every household the c of which means height, can you calculate the minimal money the whole village need so that every household has water, or tell the leader if it can’t be done.
 

Input
Multiple cases.
First line of each case contains 4 integers n (1<=n<=1000), the number of the households, X (1<=X<=1000), Y (1<=Y<=1000), Z (1<=Z<=1000).
Each of the next n lines contains 3 integers a, b, c means the position of the i‐th households, none of them will exceeded 1000.
Then next n lines describe the relation between the households. The n+i+1‐th line describes the relation of the i‐th household. The line will begin with an integer k, and the next k integers are the household numbers that can build a water line from the i‐th household.
If n=X=Y=Z=0, the input ends, and no output for that.
 

Output
One integer in one line for each case, the minimal money the whole village need so that every household has water. If the plan does not exist, print “poor XiaoA” in one line.
 

Sample Input
  
  
2 10 20 30 1 3 2 2 4 1 1 2 2 1 2 0 0 0 0
 

Sample Output
  
  
30
Hint
In 3‐dimensional space Manhattan distance of point A (x1, y1, z1) and B(x2, y2, z2) is |x2‐x1|+|y2‐y1|+|z2‐z1|.
 

Source
 
题意:给定n个点的三维坐标, 以及根节点到每个点的单向权值,再给定n个节点间相互单向连接的成本,求最小树形图。

题解:水源可以看作从虚拟根节点引出来的,这道题必定有解,因为大不了每个实际点都跟根节点相连嘛,所以ZL_MST函数里的判断非根无入边节点可以忽略掉。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <limits.h>
#define maxn 1002
#define maxm 1000002

int X, Y, Z;
struct Node{
	int x, y, z;
} ver[maxn];
struct Node2{
	int u, v, cost;
} E[maxm];
int in[maxn], hash[maxn], vis[maxn], pre[maxn];

int calDist(Node a, Node b){
	return abs(a.x - b.x) + abs(a.y - b.y) + abs(a.z - b.z);
}

__int64 ZL_MST(int root, int nv, int ne)
{
	__int64 ans = 0;
	int u, v, i, cnt;
	while(true){
		//0.初始化
		for(i = 0; i < nv; ++i) in[i] = INT_MAX;
		//1.找最小入边集
		for(i = 0; i < ne; ++i){
			u = E[i].u; v = E[i].v;
			if(E[i].cost < in[v] && u != v){
				in[v] = E[i].cost; pre[v] = u;
			}
		}
		//2.找非根无入边点(略),因为必定有解
		//3.找环,加权,重新标号
		memset(hash, -1, sizeof(hash));
		memset(vis, -1, sizeof(vis));
		cnt = in[root] = 0;
		for(i = 0; i < nv; ++i){
			ans += in[i]; v = i;
			while(vis[v] != i && v != root && hash[v] == -1){
				vis[v] = i; v = pre[v];
			}
			if(v != root && hash[v] == -1){
				for(u = pre[v]; u != v; u = pre[u])
					hash[u] = cnt;
				hash[v] = cnt++;
			}
		}
		if(cnt == 0) return ans; //无环,算法完成
		for(i = 0; i < nv; ++i) 
			if(hash[i] == -1) hash[i] = cnt++;
		//4.缩点,遍历每一条边,重新构图
		for(i = 0; i < ne; ++i){
			v = E[i].v;
			E[i].u = hash[E[i].u];
			E[i].v = hash[E[i].v];
			if(E[i].u != E[i].v) E[i].cost -= in[v];
		}
		//顶点数减少
		nv = cnt; root = hash[root];
	}
	return ans;
}

int main()
{
	int n, i, a, b, id;
	while(scanf("%d%d%d%d", &n, &X, &Y, &Z) != EOF && (n||X||Y||Z)){
		for(i = 0; i < n; ++i)
			scanf("%d%d%d", &ver[i].x, &ver[i].y, &ver[i].z);
		for(i = id = 0; i < n; ++i){
			scanf("%d", &a);
			while(a--){
				scanf("%d", &b);
				E[id].cost = calDist(ver[i], ver[--b]) * Y;
				if(ver[b].z > ver[i].z) E[id].cost += Z;
				E[id].u = i; E[id++].v = b;
			}
		}
		for(i = 0; i < n; ++i){
			E[id].u = n; E[id].v = i;
			E[id++].cost = ver[i].z * X;
		}
		printf("%I64d\n", ZL_MST(n, n + 1, id));
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值