HDU1055 POJ2054 Color a Tree

Color a Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1068    Accepted Submission(s): 349


Problem Description
Bob is very interested in the data structure of a tree. A tree is a directed graph in which a special node is singled out, called the "root" of the tree, and there is a unique path from the root to each of the other nodes.

Bob intends to color all the nodes of a tree with a pen. A tree has N nodes, these nodes are numbered 1, 2, ..., N. Suppose coloring a node takes 1 unit of time, and after finishing coloring one node, he is allowed to color another. Additionally, he is allowed to color a node only when its father node has been colored. Obviously, Bob is only allowed to color the root in the first try.

Each node has a “coloring cost factor”, Ci. The coloring cost of each node depends both on Ci and the time at which Bob finishes the coloring of this node. At the beginning, the time is set to 0. If the finishing time of coloring node i is Fi, then the coloring cost of node i is Ci * Fi.

For example, a tree with five nodes is shown in Figure-1. The coloring cost factors of each node are 1, 2, 1, 2 and 4. Bob can color the tree in the order 1, 3, 5, 2, 4, with the minimum total coloring cost of 33.



Given a tree and the coloring cost factor of each node, please help Bob to find the minimum possible total coloring cost for coloring all the nodes.
 

Input
The input consists of several test cases. The first line of each case contains two integers N and R (1 <= N <= 1000, 1 <= R <= N), where N is the number of nodes in the tree and R is the node number of the root node. The second line contains N integers, the i-th of which is Ci (1 <= Ci <= 500), the coloring cost factor of node i. Each of the next N-1 lines contains two space-separated node numbers V1 and V2, which are the endpoints of an edge in the tree, denoting that V1 is the father node of V2. No edge will be listed twice, and all edges will be listed.

A test case of N = 0 and R = 0 indicates the end of input, and should not be processed.
 

Output
For each test case, output a line containing the minimum total coloring cost required for Bob to color all the nodes.
 

Sample Input
  
  
5 1 1 2 1 2 4 1 2 1 3 2 4 3 5 0 0
 

Sample Output
  
  
33
 

Source

参考

#include <stdio.h>
#include <string.h>
#define maxn 1002

struct Node{
	int pre, c, t;
	double w;
} V[maxn];

int findMax(int n, int root)
{
	int i, u;
	double maxv = -1;
	for(i = 1; i <= n; ++i){
		if(V[i].w > maxv && i != root){
			maxv = V[i].w; u = i;
		}
	}
	return u;
}

int main()
{
	int n, root, i, ans, a, b, m, pre, j;
	while(scanf("%d%d", &n, &root), n || root){
		for(i = 1, ans = 0; i <= n; ++i){
			scanf("%d", &V[i].c);
			ans += V[i].c; V[i].t = 1;
			V[i].w = V[i].c;
		}
		for(i = 1; i < n; ++i){
			scanf("%d%d", &a, &b);
			V[b].pre = a;
		}
		for(i = 1; i < n; ++i){
			m = findMax(n, root);
			V[m].w = 0; pre = V[m].pre;
			ans += V[m].c * V[pre].t;
			for(j = 1; j <= n; ++j)
				if(V[j].pre == m) V[j].pre = pre;
			V[pre].c += V[m].c;
			V[pre].t += V[m].t;
			V[pre].w = (double)V[pre].c / V[pre].t;
		}
		printf("%d\n", ans);
	}
	return 0;
}

2015.04.16

#include <iostream>
#include <string>
#include <queue>

using namespace std;

const int maxn = 1010;
int N, R, result;
struct Node {
    int val, pre, cnt;
    double w;
} node[maxn];

void getMap()
{
    result = 0;
    for (int i = 1; i <= N; ++i) {
        cin >> node[i].val;
        result += node[i].val;
    }
    for (int i = 1; i < N; ++i) {
        int u, v;
        cin >> u >> v;
        node[v].pre = u;
        node[v].cnt = 1;
        node[v].w = node[v].val;
    }
    node[R].w = node[R].val;
    node[R].cnt = 1;
    node[R].pre = 0;
}

int findMaxW()
{
    int u = -1;
    double w = -1.0;

    for (int i = 1; i <= N; ++i)
        if (node[i].w > w && i != R)
            w = node[u = i].w;

    return u;
}

void moveChildrenToParent(int pre, int index)
{
    for (int i = 1; i <= N; ++i) {
        if (node[i].pre == index)
            node[i].pre = pre;
    }
}

int solve()
{
    for (int i = 1; i < N; ++i) {
        int index = findMaxW();
        int pre = node[index].pre;

        result += node[pre].cnt * node[index].val;
        node[pre].cnt += node[index].cnt;
        node[pre].val += node[index].val;
        node[pre].w = (double) node[pre].val / node[pre].cnt;

        node[index].w = -1.0;
        moveChildrenToParent(pre, index);
    }

    return result;
}

int main()
{
    while (cin >> N >> R, N | R) {
        getMap();
        cout << solve() << endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值