HDU5024 Wang Xifeng's Little Plot 【记忆化搜索】

Wang Xifeng's Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 319    Accepted Submission(s): 214


Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao's wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao.

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn't want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu's room and Baochai's room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai's room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu's room and Baochai's room. Now you can solve this big problem and then become a great redist.
 

Input
The map of Da Guan Yuan is represented by a matrix of characters '.' and '#'. A '.' stands for a part of road, and a '#' stands for other things which one cannot step onto. When standing on a '.', one can go to adjacent '.'s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.
 

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai's rooms. A road's length is the number of '.'s it includes. It's guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
  
  
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
  
  
3 4 3 5
 

Source

题意:在给定图中'.'为空地,空地上的点可以往八个方向走(左0,左上1,上2,右上3..)在最多只能有一次拐弯且拐弯只能为直角的情况下求合法路径的最长距离。

题解:以该直角为关键进行枚举分两条直角边搜索下去。

#include <stdio.h>
#include <string.h>
#define maxn 102

char map[maxn][maxn];
int dist[maxn][maxn][8], n;
int dir[8][2] = {0, -1, -1, -1, -1, 0, -1, 1,
                 0, 1, 1, 1, 1, 0, 1, -1};

int DFS(int x, int y, int dire) {
    if(dist[x][y][dire]) return dist[x][y][dire];
    if(x < 0 || y < 0 || x >= n || y >= n || map[x][y] == '#') 
        return 0;
    return dist[x][y][dire] = 1 + DFS(x + dir[dire][0], y + dir[dire][1], dire);
}

int main(int argc, char *argv[]) {
    int i, j, k, ans, tmp;
    while(scanf("%d", &n), n) {
        for(i = 0; i < n; ++i)
            scanf("%s", map[i]);
        memset(dist, 0, sizeof(dist));
        for(i = ans = 0; i < n; ++i)
            for(j = 0; j < n; ++j)
                if(map[i][j] == '.') {
                    tmp = DFS(i, j, 0) + DFS(i, j, 2);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 0) + DFS(i, j, 6);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 1) + DFS(i, j, 3);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 1) + DFS(i, j, 7);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 2) + DFS(i, j, 4);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 3) + DFS(i, j, 5);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 4) + DFS(i, j, 6);
                    if(tmp > ans) ans = tmp;
                    tmp = DFS(i, j, 5) + DFS(i, j, 7);
                    if(tmp > ans) ans = tmp;
                }
        printf("%d\n", ans - 1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值