POJ3279 Fliptile 【DFS】

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 3487 Accepted: 1351

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

Source

/*
** Problem: POJ3279
** Status: Accepted
** Running time: 407ms 
** Complier: C++
** Author: Changmu
**
** 题意:有一个M*N的棋盘,每一个格子只有两种状态0或1,每次可以选择一个
** 格子执行翻转操作,并且与该格子相邻的4个格子都会被翻转,求将所有格子
** 都翻转成0所需要的最小操作数.若有多种方案,输出字典序最小的方案数(这句话删掉2015.4.14)。
**
** 题解:枚举第一行的所有翻转状态,在此基础上深搜剩余行的翻转状态。
*/

#include <stdio.h>
#include <string.h>

#define maxn 16
#define inf 0x3f3f3f3f

int cow[maxn][maxn], M, N; // 原始数据 M rows
int flip[maxn][maxn]; // 保存中间结果
int opt[maxn][maxn]; // 保存最优结果
const int mov[][2] = {0, 0, 0, -1, 0, 1, -1, 0}; // 中左右上

void getMap() {
    int i, j;
    for(i = 0; i < M; ++i)
        for(j = 0; j < N; ++j)
            scanf("%d", &cow[i][j]);
}

int getColo(int x, int y) {
    int c = cow[x][y], xa, ya, i;
    for(i = 0; i < 4; ++i) {
        xa = x + mov[i][0];
        ya = y + mov[i][1];
        if(xa >= 0 && xa < M && ya >= 0 && ya < N) {
            c += flip[xa][ya];
        }
    }
    return c & 1;
}

int DFS(int k) {
    int i, j, sum;
    if(k == M - 1) { // 最后一行不再翻转,判断是否都0
        for(i = 0; i < N; ++i)
            if(getColo(k, i)) break;
        if(i != N) return -1;
        // 统计翻转次数
        for(i = sum = 0; i < M; ++i)
            for(j = 0; j < N; ++j)
                if(flip[i][j]) ++sum;
        return sum;
    }
    for(j = 0; j < N; ++j)
        if(getColo(k, j)) flip[k + 1][j] = 1;
    return DFS(k + 1);
}

void solve() {
    int i, j, maxCase = 1 << N, ret = inf, num, tmp;
    for(i = 0; i < maxCase; ++i) {
        memset(flip, 0, sizeof(flip));
        for(j = N - 1, tmp = i; j >= 0; --j, tmp >>= 1) {
            flip[0][j] = tmp & 1;
        }
        num = DFS(0);
        if(num != -1 && num < ret) {
            ret = num;
            memcpy(opt, flip, sizeof(flip));
        }
    }

    if(ret == inf) printf("IMPOSSIBLE\n");
    else {
        for(i = 0; i < M; ++i)
            for(j = 0; j < N; ++j)
                if(j == N - 1) printf("%d\n", opt[i][j]);
                else printf("%d ", opt[i][j]);
    }
}

int main() {
    // freopen("stdin.txt", "r", stdin);
    while(scanf("%d%d", &M, &N) == 2) {
        getMap();
        solve();
    }
    return 0;
}


2015.04.14

#include <stdio.h>
#include <string.h>

const int maxn = 20;
bool raw[maxn][maxn];       // raw input
bool tmp[maxn][maxn];       // reverse current status
bool ret[maxn][maxn];       // record the operation
int M, N; // M rows

void getMap()
{
    int i, j, v;

    for (i = 1; i <= M; ++i)
        for (j = 1; j <= N; ++j) {
            scanf("%d", &v);
            raw[i][j] = v;
        }
}

void reverseFlip(int k)
{
    for (int i = 1; i <= N; ++i) {
        if (ret[k][i]) {
            tmp[k][i] = !tmp[k][i];
            tmp[k+1][i] = !tmp[k+1][i];
            tmp[k-1][i] = !tmp[k-1][i];
            tmp[k][i-1] = !tmp[k][i-1];
            tmp[k][i+1] = !tmp[k][i+1];
        }
    }
    
}

void writeToRet(int k)
{
    for (int i = 0; i < N; ++i) {
        if (k & (1 << i))
            ret[1][i + 1] = true;
    }

    for (int i = 0, j = 0; i <= M; ++i)
        for (j = 0; j <= N; ++j)
            tmp[i][j] = raw[i][j];

    reverseFlip(1);
}

void markFlip(int row)
{
    for (int i = 1; i <= N; ++i) {
        if (tmp[row-1][i]) {
            ret[row][i] = true;
        }
    }

    reverseFlip(row);
}

bool checkLine(int k)
{
    for (int i = 1; i <= N; ++i)
        if (tmp[k][i]) return false;
    return true;
}

void output()
{
    for (int i = 1; i <= M; ++i) {
        for (int j = 1; j <= N; ++j)
            printf("%d%c", ret[i][j] ? 1 : 0, j == N ? '\n' : ' ');
    }
}

void solve()
{
    int i, j, k;

    for (k = 0; k < (1 << N); ++k) {
        memset(ret, 0, sizeof(ret));

        writeToRet(k);

        for (i = 2; i <= M; ++i)
            markFlip(i);

        if (checkLine(M)) {
            output();
            return;
        }
    }

    puts("IMPOSSIBLE");
}

int main()
{
    while (scanf("%d%d", &M, &N) == 2) {
        memset(ret, 0, sizeof(ret));

        getMap();
        solve();
    }
    return 0;
}



 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值