无向连通图求桥+缩点+LCA

Network
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 7082 Accepted: 2555

Description

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ A ≠ B ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ A ≠ B ≤ N), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input

3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0

Sample Output

Case 1:
1
0

Case 2:
2
0
题意:给出n个点,m条边的连通图,然后有q次询问,每次询问u和v,代表把u和v连接之后此时的图还有多少个桥,(加上的边不在去掉)
分析:如果每次询问加入边之后都进行一次tarjan则会超时,可以先按照桥缩点成一棵树,原来的桥是现在的树的边,每次加入一条边<u,v>之后,把u和v进行LCA,标记一下此时有多少路径被标记,则此时的桥的个数是num-sum;
#include"cstdio"
#include"cstring"
#include"cstdlib"
#include"cmath"
#include"string"
#include"map"
#include"cstring"
#include"iostream"
#include"algorithm"
#include"queue"
#include"stack"
#define inf 0x3f3f3f3f
#define M 100009
#define eps 1e-8
#define INT int
using namespace std;
struct node
{
    int u,v,next;
}edge[M*10],e[M*10];
stack<int>q;
int t,head[M],dfn[M],low[M],indx,cut[M*10],num,cnt,belong[M],use[M],suo[M],mark[M*10],pre[M],pp[M],ranks[M],ans;
void init()
{
    t=0;
    memset(head,-1,sizeof(head));
}
void add(int u,int v)
{
    edge[t].u=u;
    edge[t].v=v;
    edge[t].next=head[u];
    head[u]=t++;
}
void tarjan(int u,int id)//求桥
{
    dfn[u]=low[u]=++indx;
    q.push(u);
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(id==(i^1))continue;
        if(!dfn[v])
        {
            tarjan(v,i);
            low[u]=min(low[u],low[v]);
            if(low[v]>dfn[u])
            {
                cut[++num]=i;
                mark[i]=mark[i^1]=1;//存桥的编号,且把其进行标记
            }

        }
        else
        low[u]=min(low[u],dfn[v]);
    }
}
void slove(int n)
{
    num=indx=0;
    memset(low,0,sizeof(low));
    memset(dfn,0,sizeof(dfn));
    memset(cut,0,sizeof(cut));
    memset(mark,0,sizeof(mark));
    for(int i=1;i<=n;i++)
    {
        if(!dfn[i])
            tarjan(i,-1);
    }
    return ;
}
void dfs(int u,int tep)
{
    use[u]=1;
    suo[u]=tep;
    for(int i=head[u];~i;i=edge[i].next)
    {
        if(mark[i])continue;
        int v=edge[i].v;
        if(!use[v])
            dfs(v,tep);
    }
}
void DFS(int u,int fa)
{
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(fa==v)continue;
        pre[v]=u;
        ranks[v]=ranks[u]+1;
        DFS(v,u);
    }
}
void LCA(int u,int v)
{
    while(u!=v)
    {
        if(ranks[u]>ranks[v])
        {
            if(!pp[u])
            {
                ans++;
                pp[u]=1;
            }
            u=pre[u];
        }
        else
        {
            if(!pp[v])
            {
                pp[v]=1;
                ans++;
            }
            v=pre[v];
        }
    }

}
void litter(int n)
{
    cnt=0;
    memset(suo,0,sizeof(suo));
    memset(use,0,sizeof(use));
    for(int i=1;i<=num;i++)//缩点
    {
        int u=edge[cut[i]].u;
        if(!suo[u])
        {
            dfs(u,++cnt);
        }
        int v=edge[cut[i]].v;
        if(!suo[v])
            dfs(v,++cnt);
        e[i].u=u;
        e[i].v=v;
    }
   // for(int i=1;i<=n;i++)
        //printf("%d %d\n",i,suo[i]);
    init();
    for(int i=1;i<=num;i++)
    {
        int u=e[i].u;
        int v=e[i].v;
        add(suo[u],suo[v]);
        add(suo[v],suo[u]);
    }//把缩点后的图建成一棵树
    memset(pre,-1,sizeof(pre));
    ranks[1]=1;
    DFS(1,1);
    int Q;
    cin>>Q;
    int sum=0;
    memset(pp,0,sizeof(pp));
    while(Q--)
    {
        int a,b;
        scanf("%d%d",&a,&b);
        ans=0;
        LCA(suo[a],suo[b]);
        sum+=ans;
        printf("%d\n",num-sum);
    }
    printf("\n");

}
int main()
{
    int n,m,a,b,kk=1;
    while(scanf("%d%d",&n,&m),n||m)
    {
        init();
        for(int i=0;i<m;i++)
        {
            scanf("%d%d",&a,&b);
            add(a,b);
            add(b,a);
        }
        slove(n);
        printf("Case %d:\n",kk++);
        litter(n);

    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值