HDU yt13双周赛1001 Digital Roots

Digital Roots

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 64   Accepted Submission(s) : 15
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24
39
0

Sample Output

6
3
思路:根据题目的规则,我们很容易的想到,先用循环求出各位数之和s,然后判断和s是否是一个一位数,是则输出,否则继续循环。结果就会有类似于以下的代码:
#include <iostream>
using namespace std;
long long int check(long long int n)//求各位数 的函数
{
    long long int a;
    long long int s=0;
    for(;;)
    {
        a=n%10;
        s=s+a;
        if(n/10==0)
            break;
        n=n/10;
    }
    return s;
}
int main()
{
    long long int n;
    long long int s;
    while(cin>>n&&n!=0)
    {
        s=check(n);//先求出各位数
        while(s/10!=0)//判断是不是一位数
        {
            s=check(s);//不是则继续
        }
        cout<<s<<endl;//否则输出
    }
    return 0;
}
当你高兴地看到测试数据都正确的时候,就兴冲冲的叫了上去,结果发现,wrong answer。结果不对,为何?在检查一遍算法,发现算法没有错时,就该考虑了,是不是数据太大了?超出了long long int 的范围?自然应该想到整数类型无法满足了,那麽就应该想到用字符型,或者double型的,double型可能不太好处理,所以改用字符型(由于我个人实在对于字符型不太喜欢,所以喜欢,所以我不太习惯用,但有时其实挺好用的)。
代码:
#include <iostream>
#include<cstdio>
using namespace std;
long long int check(long long int n)
{
    long long int a;
    long long int s=0;
    for(;;)
    {
        a=n%10;
        s=s+a;
        if(n/10==0)
            break;
        n=n/10;
    }
    return s;
}
int main()
{
    long long int i;
    long long int s;
    char c[1000];
    while(scanf("%s",c)!=EOF&&c[0]!='0')//字符型的n
    {
        s=0;
       for(i=0;c[i]!='\0';i++)
       {
           s=s+c[i]-'0';//各位数相加
       }
        while(s/10!=0)判断是否是一位数
        {
            s=check(s);//不是泽继续
        }
        cout<<s<<endl;//是则输出
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值