HDU 5017 Ellipsoid(退火模拟)

Ellipsoid

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 658    Accepted Submission(s): 196
Special Judge

点击打开题目
Problem Description
Given a 3-dimension ellipsoid(椭球面)

your task is to find the minimal distance between the original point (0,0,0) and points on the ellipsoid. The distance between two points (x 1,y 1,z 1) and (x 2,y 2,z 2) is defined as
 

Input
There are multiple test cases. Please process till EOF.

For each testcase, one line contains 6 real number a,b,c(0 < a,b,c,< 1),d,e,f (0 ≤ d,e,f < 1), as described above. It is guaranteed that the input data forms a ellipsoid. All numbers are fit in double.
 

Output
For each test contains one line. Describes the minimal distance. Answer will be considered as correct if their absolute error is less than 10 -5.
 

Sample Input
  
  
1 0.04 0.01 0 0 0
 

Sample Output
  
  
1.0000000
 

Source
 

参照了网上的程序,自己写了一遍。

利用退货模拟搜寻最优解;
这是一个不断搜寻最优解的过程,知道最后达到要求的精度的时候不再搜索了就;
代码:
#include <iostream>
#include <math.h>
#include <stdio.h>
#include <string.h>
#define INF 0x3f3f3f3f
#define N 8            
using namespace std;
double a,b,c,d,e,f;
const double r=0.99,eps=1e-9;///r是降温速度,eps是误差
int dir[][2]={{0,1},{0,-1},{1,0},{-1,0},{1,1},{1,-1},{-1,1},{-1,-1}};///搜索的八个方向(也可以是四个)
double dis(double x,double y,double z)
{
    return sqrt(x*x+y*y+z*z);
}
double getz(double x,double y)///根据x,y获取z的值(二元一次方程)
{
    double A=c;
    double B=d*y+e*x;
    double C=a*x*x+b*y*y+f*x*y-1;
    double detal=B*B-4*A*C;
    if(detal<eps)
        return INF;
    return (sqrt(detal)-B)/(2*A);
}
double slove()
{
    int i;
    double step=1;
    double x=0,y=0,z;
    while(step>eps)///步长开始降温
    {
        z=getz(x,y);
        for(i=0; i<N; i++)
        {
            double nx=x+step*dir[i][0];
            double ny=y+step*dir[i][1];
            double nz=getz(nx,ny);///获取下一个x,y,z;
            if(dis(nx,ny,nz)<dis(x,y,z))///找最优解
                x=nx,y=ny,z=nz;
        }
        step*=r;///降温
    }
    return dis(x,y,z);
}
int main()
{
    double ans;
    while(~scanf("%lf%lf%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f))
    {
        ans=slove();
        printf("%.8lf\n",ans);
    }
    return 0;
}


评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值