poj 1270 Following Orders

Following Orders
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 3834 Accepted: 1520

Description

Order is an important concept in mathematics and in computer science. For example, Zorn's Lemma states: ``a partially ordered set in which every chain has an upper bound contains a maximal element.'' Order is also important in reasoning about the fix-point semantics of programs. 


This problem involves neither Zorn's Lemma nor fix-point semantics, but does involve order. 
Given a list of variable constraints of the form x < y, you are to write a program that prints all orderings of the variables that are consistent with the constraints. 


For example, given the constraints x < y and x < z there are two orderings of the variables x, y, and z that are consistent with these constraints: x y z and x z y. 

Input

The input consists of a sequence of constraint specifications. A specification consists of two lines: a list of variables on one line followed by a list of contraints on the next line. A constraint is given by a pair of variables, where x y indicates that x < y. 


All variables are single character, lower-case letters. There will be at least two variables, and no more than 20 variables in a specification. There will be at least one constraint, and no more than 50 constraints in a specification. There will be at least one, and no more than 300 orderings consistent with the contraints in a specification. 


Input is terminated by end-of-file. 

Output

For each constraint specification, all orderings consistent with the constraints should be printed. Orderings are printed in lexicographical (alphabetical) order, one per line. 


Output for different constraint specifications is separated by a blank line. 

Sample Input

a b f g
a b b f
v w x y z
v y x v z v w v

Sample Output

abfg
abgf
agbf
gabf

wxzvy
wzxvy
xwzvy
xzwvy
zwxvy
zxwvy

这道题目应该是先于poj1128 做的,可是我的顺序做反,在做了poj1128,相信这道题目已经变得极其水。

具体题解:看我的poj1128解题报告。

代码:

#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;

char s[10010],ans[30];
int vis[26],exist[26],indeg[26];
int adj[26][26];
int tot;
void dfs(int cur,int dp){
    ans[dp]=cur+'a';
    if(dp==tot){
        ans[dp+1]='\0';
        puts(ans+1);
        return;
    }
    vis[cur]=1;
    for(int i=0;i<26;i++)
        if(exist[i]&&!vis[i]&&adj[cur][i])
            indeg[i]-=adj[cur][i];
    for(int i=0;i<26;i++)
        if(exist[i]&&!vis[i]&&!indeg[i])
            dfs(i,dp+1);
    for(int i=0;i<26;i++)
        if(exist[i]&&!vis[i]&&adj[cur][i])
            indeg[i]+=adj[cur][i];
    vis[cur]=0;
}
int main()
{
    char a,b,c,cas=0;
    while(gets(s)){
        if(cas++) puts("");
        memset(exist,0,sizeof exist);
        tot=0;
        for(int i=0;s[i];i++)
            if(isalpha(s[i])) exist[s[i]-'a']=1,tot++;
        memset(adj,0,sizeof adj);
        memset(indeg,0,sizeof indeg);
        while(scanf("%c %c%c",&a,&b,&c),c!='\n'){
            adj[a-'a'][b-'a']++;
            indeg[b-'a']++;
        }
        adj[a-'a'][b-'a']++;
        indeg[b-'a']++;
        memset(vis,0,sizeof vis);
        for(int i=0;i<26;i++)
            if(exist[i]&&!vis[i]&&!indeg[i]) dfs(i,1);
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值