poj 3687 Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11058 Accepted: 3158

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

这题被坑惨了,首先题意理解错误,并且需要输出什么内容没有看清。

题目要求给n个重量分别为1~n的求编号1~n,如果存在多种方案,输出编号1的重量最小,编号2的重量次小。。。首先得满足编号1的重量最小,再去考虑编号为2的球,之前我一直理解成了重量相同的情况下,编号尽量小,因此正向建图是错误的。比如4->1,2->3,按照我的错误理解,现在要分重量1,那么我们选择编号为2的球,然后重量2分给编号3...这样下来重量4分给了编号1.这显然不是题目的意思。

题目的意思是将较轻重量分给编号1,那么肯定是将重量1分给4,重量2分给1了。。。但这样的话,我们无法知道编号1在哪一块。因此需要反向建图。1->4,3->2,这样先分重量大的球,尽量让1晚点分到重量,那么1就会最轻了。

不过我们得到的数组表示的重量为n-i的球的编号,因此还得转换成编号为i的重量,这个是不是有点像后缀数组和名次数组的关系,两者是互逆的,这题真的没理解题意,跪得好惨!


代码:

#include<cstdio>
#include<iostream>
#include<queue>
#include<cstring>
#define Maxn 210
using namespace std;

int adj[Maxn][Maxn],indeg[Maxn];
int tot,ans[Maxn],w[Maxn];
bool topo_sort(int n){
    priority_queue<int,vector<int> > q;
    for(int i=1;i<=n;i++)
        if(!indeg[i]) q.push(i);
    tot=0;
    while(!q.empty()){
        int t=q.top();
        q.pop();
        ans[tot++]=t;
        for(int i=1;i<=n;i++)
            if(adj[t][i]&&!(indeg[i]-=adj[t][i])) q.push(i);
    }
    if(tot==n) return false;
    return true;
}
int main()
{
    int t,n,m,a,b;
    scanf("%d",&t);
    while(t--){
        scanf("%d%d",&n,&m);
        memset(adj,0,sizeof adj);
        memset(indeg,0,sizeof indeg);
        for(int i=0;i<m;i++){
            scanf("%d%d",&a,&b);
            adj[b][a]++;
            indeg[a]++;
        }
        if(topo_sort(n)) puts("-1");
        else{
            for(int i=0;i<tot;i++)
                w[ans[i]]=n-i;
            printf("%d",w[1]);
            for(int i=2;i<=n;i++)
                printf(" %d",w[i]);
            puts("");
        }
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值