Solve It +uva+赤果果的二分

Problem F

Solve It

Input: standard input

Output: standard output

Time Limit: 1 second

Memory Limit: 32 MB

Solve the equation:
        p*e-x q*sin(x) + r*cos(x) + s*tan(x) + t*x2 + u = 0
        where 0 <= x <= 1.

Input

Input consists of multiple test cases and terminated by an EOF. Each test case consists of 6 integers in a single line: pqrst and u (where 0 <= p,r <= 20 and -20 <= q,s,t <= 0). There will be maximum 2100 lines in the input file.

Output

For each set of input, there should be a line containing the value of x, correct upto 4 decimal places, or the string "No solution", whichever is applicable.

Sample Input

0 0 0 0 -2 1
1 0 0 0 -1 2
1 -1 1 -1 -1 1

Sample Output

0.7071
No solution
0.7554
解决方案:二分枚举即可。
代码:
#include<iostream>
#include<cstdio>
#include<cmath>
#include<complex>
using namespace std;
double p,q,r,s,t,u;
double sum(double x){

 return ( p*exp(-1.0*x) + q*sin(x) + r*cos(x) + s*tan(x) + t*x*x + u );

}
int main(){

   while(~scanf("%lf%lf%lf%lf%lf%lf",&p,&q,&r,&s,&t,&u)){


   double low=0.0;
   double m;
   double high=1.0;
   if(sum(0.0)<0.0||sum(1.0)>0.0)
   printf("No solution\n");
   else{
   while(abs(high-low)>=1e-10){
   m=(high+low)/2.0;


  if(sum(m)>0) low=m;
   else high=m;

   }
   printf("%.4lf\n",low);
   }

   }

   return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值