Hotel+POJ+线段树区间合并

Hotel
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 11788 Accepted: 5086

Description

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and D(b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5
解决方案:要用到4个数组:sum[],lsum[],rsum[],cover[];sum[]标记节点最大连续长度;lsum[]标记从左端点开始的最大连续长度;rsum[]标记从右端开始的最大连续长度;cover[]标记区间是否已被占满。然后在更新查询时进行区间合并即可。
code:
#include<iostream>
#include<cstdio>
#include<cstring>
#define MMAX  55555
#define lson L,M,rt<<1
#define rson M+1,R,rt<<1|1
using namespace std;
int cover[MMAX<<2];///覆盖点标记
int lsum[MMAX<<2];///该节点的从左端点最大连续长度
int rsum[MMAX<<2];///该节点从右段点开始的最大连续长度
int sum[MMAX<<2];///该节点的最大连续长度
void build(int L,int R,int rt)
{
    sum[rt]=lsum[rt]=rsum[rt]=R-L+1;
    cover[rt]=-1;
    if(L==R)
    {
        return ;
    }
    int M=(L+R)>>1;
    build(lson);
    build(rson);

}
void push_down(int rt,int m)
{
    if(cover[rt]!=-1)
    {
        cover[rt<<1]=cover[rt<<1|1]=cover[rt];
        sum[rt<<1]=lsum[rt<<1]=rsum[rt<<1]=cover[rt]?0:m-(m>>1);
        sum[rt<<1|1]=lsum[rt<<1|1]=rsum[rt<<1|1]=cover[rt]?0:m>>1;
        cover[rt]=-1;
    }

}
void push_up(int rt,int m)
{
    lsum[rt]=lsum[rt<<1];
    rsum[rt]=rsum[rt<<1|1];
    if(lsum[rt]==m-(m>>1)) lsum[rt]+=lsum[rt<<1|1];
    if(rsum[rt]==m>>1) rsum[rt]+=rsum[rt<<1];
    sum[rt]=max(rsum[rt<<1]+lsum[rt<<1|1],max(sum[rt<<1],sum[rt<<1|1]));
}
void update(int l,int r,int c,int L,int R,int rt)
{

    if(l<=L&&r>=R)
    {
        sum[rt]=lsum[rt]=rsum[rt]=c?0:R-L+1;
        cover[rt]=c;
        return ;
    }
    push_down(rt,R-L+1);
    int M=(L+R)>>1;
    if(l<=M) update(l,r,c,lson);
    if(r>M) update(l,r,c,rson);
    push_up(rt,R-L+1);

}
int query(int w,int L,int R,int rt)
{

    if(L==R) return L;
    push_down(rt,R-L+1);
    int M=(L+R)>>1;
    if(sum[rt<<1]>=w) return query(w,lson);
    else if((rsum[rt<<1]+lsum[rt<<1|1])>=w) return M-rsum[rt<<1]+1;
    else return query(w,rson);

}
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        build(1,n,1);
        for(int i=0; i<m; i++)
        {
            int op;
            scanf("%d",&op);
            if(op==1)
            {
                int c;
                scanf("%d",&c);
                if(sum[1]<c)
                {
                    printf("0\n");
                    continue;
                }
                int l=query(c,1,n,1);
                printf("%d\n",l);
                update(l,l+c-1,1,1,n,1);
            }
            else
            {
                int a,b;
                scanf("%d%d",&a,&b);
                update(a,b+a-1,0,1,n,1);
            }
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值