Sicily 1089. Farey Sequence

1089. Farey Sequence

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

The Farey Sequence Fn for any integer n with n >= 2 is the set of irreducible rational numbers a/b with 0 < a < b <= n and gcd(a,b) = 1 arranged in increasing order. The first few are 
F2 = {1/2}
F3 = {1/3, 1/2, 2/3}
F4 = {1/4, 1/3, 1/2, 2/3, 3/4}
F5 = {1/5, 1/4, 1/3, 2/5, 1/2, 3/5, 2/3, 3/4, 4/5}

You task is to calculate the number of terms in the Farey sequence Fn.

Input

There are several test cases. Each test case has only one line, which contains a positive integer n (2 <= n <= 106). There are no blank lines between cases. A line with a single 0 terminates the input.

Output

For each test case, you should output one line, which contains N(n) ---- the number of terms in the Farey sequence Fn.

Sample Input

2
3
4
5
0

Sample Output

1
3
5

9

// Problem#: 1089
// Submission#: 3287981
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
// URI: http://creativecommons.org/licenses/by-nc-sa/3.0/
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
#include <stdio.h>
#include <iostream>
#include <vector>
#include <string>
#include <stack>
#include <iomanip>
#include <algorithm>
#include <queue>
#include <functional>
using namespace std;

const int MAX_N = 1000005;

int m[MAX_N], phi[MAX_N], p[MAX_N], pt;

void make() {
    phi[1] = 1;
    int N = MAX_N;
    int k;
    phi[1] = 1;
    for (int i = 2; i < N; i++) {
        if (!m[i]) {
            p[pt++] = m[i] = i;
            phi[i] = i - 1;
        }
        for (int j = 0; j < pt && (k = p[j] * i) < N; j++) {
            m[k] = p[j];
            if (m[i] == p[j]) {
                phi[k] = phi[i] * p[j];
                break;
            } else {
                phi[k] = phi[i] * (p[j] - 1);
            }
        }
    }
}

long long int ans[MAX_N];

void cal() {
    long long int sum = 0;
    for (int i = 2; i <= 1000000; i++) {
        sum += phi[i];
        ans[i] = sum;
    }
}

int main() {

    std::ios::sync_with_stdio(false);

    make();
    cal();

    while (1) {
        int temp;
        cin >> temp;
        if (!temp) break;
        cout << ans[temp] << endl;
    }

    return 0;
}                                 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值