1150 Message Flood 【字典树】

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3

来源

第9届中山大学程序设计竞赛预选赛
 
错的比较惨的一道题,如果字典树中存储的是a-a-a,那么会成为a,aa,aaa,三个字符串,所以,需要有东西标记到底是哪一个字符串。
对于这个题,在遍历的时候,还需要记录节点是不是被访问过。
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    int tf;
    int tf1;
    struct node *(a[26]);
}*root,*tmp,*now;

int goujian (char *s)
{
    char *p = s;
    int i;
    while (*p != '\0')
    {
        if (*p >= 'A' && *p <= 'Z')
        {
            *p += 32;
        }

        i = *p - 'a';
        if (now->a[i] == NULL)
        {
            tmp = new node;
            memset(tmp,0,sizeof (*tmp));
            now->a[i] = tmp;
        }
        now = now->a[i];

        p++;
    }
    now->tf = 1;
}

int pd (char *s)
{
    int i;
    char *p = s;

    while (*p != NULL)
    {
        if (*p >= 'A' && *p <= 'Z')
        {
            *p += 32;
        }
        i = *p - 'a';
        if (now->a[i] != NULL)
        {
            now = now->a[i];
        }
        else
            return 0;

        p++;
    }
    if (now->tf == 1 && now->tf1 == 0)
    {
        now->tf == 1;
        return 1;
    }else
    return 0;
}

struct node * shifang (struct node * root)
{
    int i = 0;
    for (i = 0; i < 26; i++)
    {
        if (root->a[i] != NULL)
            root->a[i] = shifang (root->a[i]);
    }

    free (root);
    return NULL;
}

int main()
{
    int n,m,i;
    char s[15];
    char sn[20001][15];
    while (scanf ("%d",&n),n)
    {
        root = new node;
        memset(root,0,sizeof (*root));
        scanf ("%d",&m);
        for (i = 0; i < n; i++)
        {
            scanf ("%s",sn[i]);
        }
        int num = 0;
        for (i = 0; i < m; i++)
        {
            now = root;
            scanf ("%s",s);
            goujian(s);
        }
        for (i = 0; i < n; i++)
        {
            now = root;
            num += pd(sn[i]);
        }
        printf ("%d\n",n - num);

        shifang(root);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值