ZOJ 1484 Minimum Inversion Number(线段树,数论)

19 篇文章 0 订阅
8 篇文章 0 订阅

http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=1484

Minimum Inversion Number

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.


Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.


Output

For each case, output the minimum inversion number on a single line.


Sample Input

10
1 3 6 9 0 8 5 7 4 2


Sample Output

16



题意:

给出n个数(0~n-1,每个数仅出现一次),问它长为n的循环序列中逆序对最少的数量。

分析:

如序列a1,a2,a3,a4,a5,它的逆序对数量s=sum(num(ak>ai,k<i));

序列变为a2,a3,a4,a5,a1,和上一个序列相比,变化分为两步,拿走a1和将a1 放入序列尾部;拿走a1,逆序对减少a1( 整个序列是0~n-1且每个数字仅出现一次)个,加入序列尾部,逆序对增加n-1-a1个,这样就可以递推求解各序列的逆序对个数。

那么首个序列的逆序对如何求解呢?方法有很多,我采用的是线段树,维护[0,n)的区间和,每次先求出区间[ai+1,n)的和,即为ai之前比ai大的数字的个数,然后在ai位置上+1(初始化为0),这样就能求解出首个序列的逆序对个数。


#include<cstdio>
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<ctime>
#include<cctype>
#include<cmath>
#include<string>
#include<cstring>
#include<stack>
#include<queue>
#include<list>
#include<vector>
#include<map>
#include<set>
#define sqr(x) ((x)*(x))
#define LL long long
#define itn int
#define INF 0x3f3f3f3f
#define PI 3.1415926535897932384626
#define eps 1e-10
#define mm 5007

using namespace std;

int a[mm];
itn _minv[mm<<2],_maxv[mm<<2];
int _sumv[mm<<2];

void update(itn p,int k,int l,int r)
{
    if (r-l==1)
    {
        _sumv[k]=1;
        return ;
    }

    int m=l+r>>1;
    if (p<m)    update(p,k*2+1,l,m);  else    update(p,k*2+2,m,r);
    _sumv[k]=_sumv[k*2+1]+_sumv[k*2+2];
}

int query(itn a,int b,int k,int l,int r)
{
    if (b<=r || r<=a)   return 0;

    if (a<=l && r<=b)   return _sumv[k];

    return query(a,b,k*2+1,l,l+r>>1)+query(a,b,k*2+2,l+r>>1,r);
}

int main()
{
    #ifndef ONLINE_JUDGE
        freopen("/home/fcbruce/文档/code/t","r",stdin);
    #endif // ONLINE_JUDGE

    int n;

    while (~scanf("%d",&n))
    {
        for (int i=0;i<n;i++)
            scanf("%d",a+i);

        memset(_sumv,0,sizeof _sumv);

        int s=0;
        for (int i=0;i<n;i++)
        {
            s+=query(a[i]+1,n+1,0,0,n);
            update(a[i],0,0,n);
        }

        itn ans=s;
        int t=a[0];
        for (int i=1;i<n;i++)
        {
            s=s+n-1-(t<<1);
            t=a[i];
            ans=min(ans,s);
        }

        printf("%d\n",ans);
    }


    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值