poj 2965 The Pilots Brothers' refrigerator——DFS(分类是枚举)

21 篇文章 0 订阅

The Pilots Brothers' refrigerator
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 17929
Accepted: 6794
Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion

这个题和1753那个题很像,无非就是1753翻的时候是周围的都翻,而这个是翻得时候它所在的行和列都跟着翻(有个坑)...

#include <iostream>
#include <cstdlib>
#include <cstring>

using namespace std;

char mp1[4][4];
int mp2[4][4];

struct node
{
    int x;
    int y;
} ls[100010];

int pd()
{
    int i,j,js=0;
    for(i=0; i<4; i++)
    {
        for(j=0; j<4; j++)
        {
            if(mp2[i][j]==1)
            {
                js++;
            }
        }
    }
    if(js==16)
        return 1;
    return 0;
}

void fan(int x,int y)
{
    int i;
    for(i=0; i<4; i++)
    {
        if(mp2[x][i]==1)
            mp2[x][i]=0;
        else
            mp2[x][i]=1;
    }
    for(i=0; i<4; i++)
    {
        if(mp2[i][y]==1)
            mp2[i][y]=0;
        else
            mp2[i][y]=1;
    }
    if(mp2[x][y]==1)//这里是个坑,上面行翻得时候mp2[x][y],已经翻过
        mp2[x][y]=0;//了,列翻的时候又给翻回去了,所以这里要给翻回来
    else
        mp2[x][y]=1;
}

int dfs(int x,int y,int t)
{
    int bx,by,i;
    if(pd())
    {
        cout<<t<<endl;
        for(i=0; i<t; i++)
        {
            cout<<ls[i].x<<" "<<ls[i].y<<endl;
        }
        return 0;
    }
    if(x>=4||y>=4)
    {
        return 0;
    }
    bx=(x+1)%4;
    by=y+(x+1)/4;
    dfs(bx,by,t);
    fan(x,y);
    ls[t].x=x+1;
    ls[t].y=y+1;
    dfs(bx,by,t+1);
    fan(x,y);
}

int main()
{
    int i,j;
    for(i=0; i<4; i++)
    {
        cin>>mp1[i];
    }
    for(i=0; i<4; i++)
    {
        for(j=0; j<4; j++)
        {
            if(mp1[i][j]=='+')
            {
                mp2[i][j]=0;
            }
            else
            {
                mp2[i][j]=1;
            }
        }
    }
    dfs(0,0,0);
    return 0;
}

如果不明白,去看看1753那个题的题解吧....http://blog.csdn.net/codeblf2/article/details/31040891





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值