poj 3278 ——Catch That Cow(bfs)

21 篇文章 0 订阅
Catch That Cow
Time Limit: 2000MS
Memory Limit: 65536K
Total Submissions: 48099
Accepted: 15070

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source




不得不说这个题真是个奇葩:
数据范围到100000就行了,多了就MLE,少了就RE


#include <stdio.h>
#include <queue>
#include <string.h>
#include <limits.h>

using namespace std;

struct node
{
    int x;
    int ans;
}t,f;

int mn;

bool vis[1000010];

queue <node> q;

void bfs(int m,int n)
{
    mn = INT_MAX;
    memset(vis,false,sizeof(vis));
    t.x = m;
    t.ans = 0;
    vis[m] = true;
    while(!q.empty())
        q.pop();
    q.push(t);
    while(!q.empty())
    {
        t = q.front();
        q.pop();
        if(t.x == n)
        {
            printf("%d\n",t.ans);
            return ;
        }
        f.x = t.x + 1;
        if(f.x <= 100000 && f.x >= 0 && !vis[f.x])
        {
            f.ans = t.ans + 1;
            q.push(f);
            vis[f.x] = true;
        }
        f.x = t.x - 1;
        if(f.x <= 1000000 && f.x >= 0 && !vis[f.x])
        {
            f.ans = t.ans + 1;
            q.push(f);
            vis[f.x] = true;
        }
        f.x = t.x * 2;
        if(f.x <= 1000000 && f.x >= 0 && !vis[f.x])
        {
            f.ans = t.ans + 1;
            q.push(f);
            vis[f.x] = true;
        }
    }
}

int main()
{
    int m,n;
    while(~scanf("%d%d",&m,&n))
    {
//        if(m > n)
//        {
//            int tmp = m;
//            m = n;
//            n = tmp;
//        }
        bfs(m,n);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值