POJ 2488 A Knight's Journey --- DFS

21 篇文章 0 订阅

A Knight's Journey
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 32838
Accepted: 11182

Description

Background 
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey 
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans? 

Problem 
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number. 
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany


#include <stdio.h>
#include <string.h>

int bhx[] = { -1, 1, -2, 2, -2, 2, -1, 1 };
int bhy[] = { -2, -2, -1, -1, 1, 1, 2, 2 };//注意顺序按字典序从小到大是这样的
bool vis[55][55];//标记数组
struct node
{
    int x;
    int y;
} ls[1010];//记录路径的队列

bool flag;//标记是否把所有点遍历

void dfs(int sx,int sy,int p,int q,int top)//dfs搜索遍历
{
    if(flag)
        return ;
    if(top >= p * q)
    {
        flag = true;
        for(int i = 0;i < top;i++)
            {
                printf("%c%d",(char)(ls[i].x + 'A' - 1),ls[i].y);//输出答案,这里不能在最后输出,因为top每次dfs都会变,这一次搜完了并不代表完全返回
            }
            printf("\n\n");
        return ;
    }
    int a,b;
    for(int i = 0; i < 8; i++)
    {
        a = sx + bhx[i];
        b = sy + bhy[i];
        if(a >= 1 && a <= p && b >= 1 && b <= q && !vis[a][b])
        {
            ls[top].x = b;
            ls[top].y = a;
            vis[a][b] = true;
            dfs(a,b,p,q,top + 1);
            vis[a][b] = false;
        }
    }
}

int main()
{
    int t,p,q,c = 0,top;
    scanf("%d",&t);
    while(t--)
    {
        flag = false;
        printf("Scenario #%d:\n",++c);
        scanf("%d%d",&p,&q);
        for(int i = 1; i <= q; i++)
        {
            for(int j = 1; j <= p; j++)
            {
                top = 0;
                memset(vis,0,sizeof(vis));
                ls[top].x = i;
                ls[top].y = j;
                top++;
                vis[j][i] =true;
                dfs(j,i,p,q,top);
                if(flag)
                    break;
            }
            if(flag)
                break;
        }
        top = p * q;
        if(!flag)
            printf("impossible\n\n");
//        else
//        {
//            for(int i = 0;i < top;i++)
//            {
//                printf("%c%d",(char)(ls[i].y + 'A' - 1),ls[i].x);
//            }
//            printf("\n\n");
//        }
    }
    return 0;
}






评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值