Time Limit: 1000MS | Memory Limit: 65536K | |
Total Submissions: 19729 | Accepted: 7920 |
Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:
Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…
Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.
So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.
Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
- One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
- One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.
Sample Input
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
Sample Output
1 3 0
Source
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
char str1[10002] , str2[1000002] ;
int next[10002] ;
void getnext()
{
int j = 0 , k = -1 , l ;
next[0] = -1 ;
l = strlen(str1);
while(j < l )
{
if(k==-1 || str1[j]== str1[k])
{
k++;
j++;
next[j] = k ;
}
else
k = next[k];
}
}
int main()
{
int k , m , i , j , count ;
scanf("%d", &m);
for(k = 1 ; k <= m ; k++)
{
scanf("%s%s", str1, str2);
getnext();
i = 0 ; j = 0 ; count = 0;
while(str2[j] !='\0')
{
if(str1[i]==str2[j])
{
i++; j++;
}
else
{
if(next[i]==-1)
{
i = 0 ;
j++;
}
else
{
i = next[i];
}
}
if(str1[i]=='\0')
{
count++;
i = next[i] ;
}
}
printf("%d\n", count);
}
}