寒假训练--字典树--B - Compound Words

Problem E: Compound Words

You are to find all the two-word compound words in a dictionary. A two-word compound word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.

Input

Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 120,000 words.

Output

Your output should contain all the compound words, one per line, in alphabetical order.

Sample Input

a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra

Sample Output

alien
newborn
 
寻找是有两个字符串组合成的字符串,并输出,先建树,再查找时,如果遇到flag= 1 ,就跳到另一个函数里 继续查找,  如果最后仍是flag= 1  那这个字符串就是由这两个flag= 1 的字符串组成  应该输出,   如果没找到,应该退回一开始的函数里,寻找下一个flag= 1 的点,继续查找
 
#include <stdio.h>
#include <string.h>
char s[120010][50] ;
struct node{
    int flag ;
    node *next[26] ;
};
struct node *newnode()
{
    node *p = new node ;
    p->flag = 0;
    for(int i = 0 ; i < 26 ; i++)
        p->next[i] = NULL ;
    return p;
}
void gettree(node *root,char *s)
{
    int i , l = strlen(s) ;
    node *p = root ;
    for(i = 0 ; i < l ; i++)
    {
        int k = s[i] - 'a' ;
        if(p->next[k]==NULL)
            p->next[k] = newnode();
        p = p->next[k] ;
    }
    p->flag = 1 ;
}
int ff(node *root,char *s,int i, int l)
{
    node *p = root ;
    for( ; i < l ; i++)
    {
        int k = s[i] - 'a' ;
        if(p->next[k] == NULL) return 0;
        p = p->next[k] ;
    }
    if(p->flag)
    {


        printf("%s\n", s);
        return 1;
    }
    return 0;
}
void f(node *root,char *s)
{
    int i , l = strlen(s) ;
    node *p = root ;
    for(i = 0 ; i < l ; i++)
    {
        int k = s[i] - 'a' ;
        if(p->next[k] == NULL) return ;
        p = p->next[k] ;
        if(p->flag)
            if(ff(root,s,i+1,l))return;
    }
}
int main()
{
    int i , n = 0 ;
    node *head ;
    while(scanf("%s", s[n++])!=EOF)
    {
    }
    n--;
    head = newnode();
    for(i = 0 ; i < n ; i++)
        gettree(head,s[i]);
    for(i = 0 ; i < n ; i++)
        f(head,s[i]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值