poj1218--THE DRUNK JAILER(求约数的个数)

THE DRUNK JAILER
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 22732 Accepted: 14334

Description

A certain prison contains a long hall of n cells, each right next to each other. Each cell has a prisoner in it, and each cell is locked. 
One night, the jailer gets bored and decides to play a game. For round 1 of the game, he takes a drink of whiskey,and then runs down the hall unlocking each cell. For round 2, he takes a drink of whiskey, and then runs down the 
hall locking every other cell (cells 2, 4, 6, ?). For round 3, he takes a drink of whiskey, and then runs down the hall. He visits every third cell (cells 3, 6, 9, ?). If the cell is locked, he unlocks it; if it is unlocked, he locks it. He 
repeats this for n rounds, takes a final drink, and passes out. 
Some number of prisoners, possibly zero, realizes that their cells are unlocked and the jailer is incapacitated. They immediately escape. 
Given the number of cells, determine how many prisoners escape jail.

Input

The first line of input contains a single positive integer. This is the number of lines that follow. Each of the following lines contains a single integer between 5 and 100, inclusive, which is the number of cells n. 

Output

For each line, you must print out the number of prisoners that escape when the prison has n cells. 

Sample Input

2
5
100

Sample Output

2
10

Source

求一个整数的约数的个数

一个数可以化成,素数相乘的形式,约数个数 = 每个素数的次幂+1的乘积。

注意 1 的情况特判。

注意在sqrt(a)以外的素数,直接输出2。

一个非素数含有约数为sqrt(a)以外的素数的,特判,结果×2 ;


一个整数X = a1^k1 * a2^k2 * a3^k3* ···an^kn .
约数的个数n = (k1+1)*(k2+1)* ···(kn+1) .
约数的和 sum = (a1^0 + a1^1 + a1^2 ……a1^k1) * (a2^0 + a2^1 + a2^2 ……a2^k2) * ··· (an^0 + an^1 + an^2 ……an^kn).
约数的倒数的和  = sum / x 



#include <stdio.h>
#include <string.h>
#include <math.h>
int a[1000] , check[1000] ; //a数组中存储了在范围内所有的素数,check中0为素数,1为非素数;
int tot ;//素数的个数
void sushu()
{
    tot = 0 ;
    memset(check,0,sizeof(check));
    memset(a,0,sizeof(a));
    int i , j ;
    for(i = 2 ; i <= 100 ; i++)
    {
        if(!check[i])
            a[tot++] = i ;
        for(j = 0 ; j < tot ; j++)
        {
            if(i*a[j] >= 100)
                break;
            check[i*a[j]] = 1 ;
            if(i % a[j] == 0)
                break;
        }
    }
}
int yueshu(int n)
{
    int k[100] , m = n;
    memset(k,0,sizeof(k));
    if(n == 1)
        return 1 ;
    int flag = 1 , i ;
    for(i = 0 ; i < tot ; i++)
    {
        if(a[i] > sqrt(m))
            break;
        if(n%a[i] == 0)
        {
            n = n/a[i] ;
            k[i]++ ;
            flag = 0 ;
            break;
        }
    }
    if(flag)
        return 2 ;
    int sum = 1 ;
    while(n > 1)
    {
        flag = 1 ;
        for(i = 0 ; i < tot ; i++)
        {
            if(a[i] > sqrt(m))
                break;
            if(n%a[i]==0)
            {
                n = n/a[i];
                k[i]++ ;
                flag = 0 ;
                break;
            }
        }
        if(flag)
        {
            sum = 2 ;
            break;
        }
    }
    for(i = 0 ; i < tot ; i++)
    {
        if(k[i] != 0)
        {
            sum *= (k[i]+1);
        }
    }
    return sum ;
}
int main()
{
    int t , n , i , num ;
    sushu();
    scanf("%d", &t);
    while(t--)
    {
        num = 0 ;
        scanf("%d", &n);
        for(i = 1 ; i <= n ; i++)
        {
            if(yueshu(i)%2 == 1)
                num++ ;
        }
        printf("%d\n", num);
    }
    return 0 ;
}
素数筛的应用

<pre code_snippet_id="344276" snippet_file_name="blog_20140514_2_2208700" name="code" class="cpp">int a[1000] , check[1000] ; //a数组中存储了在范围内所有的素数,check中0为素数,1为非素数;
int tot ;//素数的个数
void sushu()
{
    tot = 0 ;
    memset(check,0,sizeof(check));
    memset(a,0,sizeof(a));
    int i , j ;
    for(i = 2 ; i <= 100 ; i++)
    {
        if(!check[i])
            a[tot++] = i ;
        for(j = 0 ; j < tot ; j++)
        {
            if(i*a[j] >= 100)
                break;
            check[i*a[j]] = 1 ;
            if(i % a[j] == 0)
                break;
        }
    }
}


 

 
</pre><pre code_snippet_id="344276" snippet_file_name="blog_20140514_2_2208700" name="code" class="cpp">
</pre><pre code_snippet_id="344276" snippet_file_name="blog_20140514_2_2208700" name="code" class="cpp">
</pre><pre code_snippet_id="344276" snippet_file_name="blog_20140514_2_2208700" name="code" class="cpp">
</pre><p></p><p></p><p></p><p></p><pre code_snippet_id="344276" snippet_file_name="blog_20140514_2_2208700" name="code" class="cpp">int yueshu(int n)//求约数个数 返回num
{
    int k[100] , m = n;
    memset(k,0,sizeof(k));
    if(n == 1)
        return 1 ;
    int flag = 1 , i ;
    for(i = 0 ; i < tot ; i++)
    {
        if(a[i] > sqrt(m))
            break;
        if(n%a[i] == 0)
        {
            n = n/a[i] ;
            k[i]++ ;
            flag = 0 ;
            break;
        }
    }
    if(flag)
        return 2 ;
    int sum = 1 ;
    while(n > 1)
    {
        flag = 1 ;
        for(i = 0 ; i < tot ; i++)
        {
            if(a[i] > sqrt(m))
                break;
            if(n%a[i]==0)
            {
                n = n/a[i];
                k[i]++ ;
                flag = 0 ;
                break;
            }
        }
        if(flag)
        {
            sum = 2 ;
            break;
        }
    }
    for(i = 0 ; i < tot ; i++)
    {
        if(k[i] != 0)
        {
            sum *= (k[i]+1);
        }
    }
    return sum ;
}
 
 

                
评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值