poj1068--Parencodings

Parencodings
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 19059 Accepted: 11495

Description

Let S = s1 s2...s2n be a well-formed string of parentheses. S can be encoded in two different ways: 
q By an integer sequence P = p1 p2...pn where pi is the number of left parentheses before the ith right parenthesis in S (P-sequence). 
q By an integer sequence W = w1 w2...wn where for each right parenthesis, say a in S, we associate an integer which is the number of right parentheses counting from the matched left parenthesis of a up to a. (W-sequence). 

Following is an example of the above encodings: 
	S		(((()()())))

	P-sequence	    4 5 6666

	W-sequence	    1 1 1456


Write a program to convert P-sequence of a well-formed string to the W-sequence of the same string. 

Input

The first line of the input contains a single integer t (1 <= t <= 10), the number of test cases, followed by the input data for each test case. The first line of each test case is an integer n (1 <= n <= 20), and the second line is the P-sequence of a well-formed string. It contains n positive integers, separated with blanks, representing the P-sequence.

Output

The output file consists of exactly t lines corresponding to test cases. For each test case, the output line should contain n integers describing the W-sequence of the string corresponding to its given P-sequence.

Sample Input

2
6
4 5 6 6 6 6
9 
4 6 6 6 6 8 9 9 9

Sample Output

1 1 1 4 5 6
1 1 2 4 5 1 1 3 9

Source

Tehran 2001
输入的一列数,表示字符串中)前有多少(,按照输入模拟出那一串数组,然后遍历每遇到 )后向前搜索。
#include <stdio.h>
#include <string.h>
int main()
{
    int t , n , i , j , l , top ;
    char str[100] ;
    int a[100] , k[100];
    scanf("%d", &t);
    while(t--)
    {
        scanf("%d", &n);
        for(i = 0 ; i < n ; i++)
            scanf("%d", &a[i]);
        l = 0 ; top = 0 ;
        memset(k,0,sizeof(k));
        for(i = 0 ; i < n ; i++)
        {
            while(1)
            {
                if(l == a[i])
                {
                    str[top++] = ')' ;
                    break ;
                }
                else
                {
                    str[top++] = '(' ;
                    l++ ;
                }
            }
        }
        n = 0 ;
        memset(a,0,sizeof(a));
        for(i = 0 ; i < top ; i++)
        {
            if(str[i] == ')')
            {
                j = i ;
                while(1)
                {
                    j-- ;
                    if(str[j] == '(')
                        a[n]++ ;
                    if(str[j] == '(' && k[j] == 0)
                        break;
                }
                n++ ;
                k[i] = 1 ;
                k[j] = 1 ;
            }
        }
        for(i = 0 ; i < n ; i++)
        {
            if(i == n-1)
                printf("%d\n", a[i]);
            else
                printf("%d ", a[i]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值