3259--Wormholes

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 29221 Accepted: 10555

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold
有n个农场,有m条路,走每段路需要时间t,w个虫洞,虫洞为单向的,会是你返回t时间以前,问是否有负环
简单的贝尔曼算法
#include <stdio.h>
#define maxint 999999
struct node{
    int u ,v ;
    int w ;
}p[10000];
int dis[10000] ;
int main()
{
    int f , n , m , t , i , j ;
    scanf("%d", &f);
    while(f--)
    {
        scanf("%d %d %d", &n, &m, &t);
        for(i = 1 ; i <= n ; i++)
            dis[i] = maxint ;
        i = 0 ;
        for(j = 0 ; j < m ; j++)
        {
            int u , v , w ;
            scanf("%d %d %d", &u, &v, &w);
            p[i].u = u ;
            p[i].v = v ;
            p[i++].w = w ;
            p[i].u = v ;
            p[i].v = u ;
            p[i++].w = w ;
        }
        for(j = 0 ; j < t ; j++)
        {
            int u , v , w ;
            scanf("%d %d %d", &u, &v, &w);
            p[i].u = u ;
            p[i].v = v ;
            p[i++].w = -w ;
        }
        m = i ;
        for(i = 1 ; i < n ; i++)
        {
            int flag = 1 ;
            for(j = 0 ; j < m ; j++)
                if( dis[ p[j].v ] > dis[ p[j].u ] + p[j].w )
                {
                    dis[ p[j].v ] = dis[ p[j].u ] + p[j].w ;
                    flag = 0;
                }
            if(flag)
                break;
        }
        int flag = 1 ;
        for(i = 0 ; i < m ; i++)
        {
            if( dis[ p[i].v ] > dis[ p[i].u ] + p[i].w )
                {
                    flag = 0;
                    break;
                }
        }
        if(flag)
            printf("NO\n");
        else
            printf("YES\n");

    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值