poj3687--Labeling Balls

Labeling Balls
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 9968 Accepted: 2743

Description

Windy has N balls of distinct weights from 1 unit to N units. Now he tries to label them with 1 to N in such a way that:

  1. No two balls share the same label.
  2. The labeling satisfies several constrains like "The ball labeled with a is lighter than the one labeled with b".

Can you help windy to find a solution?

Input

The first line of input is the number of test case. The first line of each test case contains two integers, N (1 ≤ N ≤ 200) and M (0 ≤ M ≤ 40,000). The next M line each contain two integers a and b indicating the ball labeled with a must be lighter than the one labeled with b. (1 ≤ a, b ≤ N) There is a blank line before each test case.

Output

For each test case output on a single line the balls' weights from label 1 to label N. If several solutions exist, you should output the one with the smallest weight for label 1, then with the smallest weight for label 2, then with the smallest weight for label 3 and so on... If no solution exists, output -1 instead.

Sample Input

5

4 0

4 1
1 1

4 2
1 2
2 1

4 1
2 1

4 1
3 2

Sample Output

1 2 3 4
-1
-1
2 1 3 4
1 3 2 4

Source

POJ Founder Monthly Contest – 2008.08.31, windy7926778
要求出第几轻的是第几个球,并且要求尽可能的使输出的字典序小
这就要求如果由小到大排序的话,需要尽量让球号小的球在前,如果正序排列的话,只能保证在当前的入度为0的点是按字典序排列,可能存在如果不为0的点中存在序号小的,却被排在了后面。
采用倒序排列,由重到轻拓扑排序,保证尽量让序号大的先被拓扑,那么序号小的自然会在后面。
#include <stdio.h>
#include <string.h>
struct node{
    int v ;
    node *next ;
} *head[300];
int in[300] ;
int p[300] , top ;
void add(int u,int v)
{
    node *q = new node ;
    q->v = u ;
    q->next = head[v];
    head[v] = q ;
}
int f(int n)
{
    int i , ans = 0 ;
    top = 0 ;
    while(1)
    {
        int u = -1 ;
        for(i = n ; i >= 1 ; i--)
        {
            if(in[i] == 0)
            {
                p[top++] = i ;
                in[i] = -1 ;
                ans++ ;
                u = i ;
                break;
            }
        }
        if(u == -1)
            return -1 ;
        if(ans == n)
            return 1 ;
        for( node *q = head[u] ; q != NULL ; q = q->next )
            in[ q->v ]-- ;
    }
}
int main()
{
    int t , i , j , n , m ;
    scanf("%d", &t);
    while(t--)
    {
        memset(in,0,sizeof(in));
        scanf("%d %d", &n, &m);
        for(i = 1 ; i <= n ; i++)
            head[i] = NULL ;
        for(i = 0 ; i < m ; i++)
        {
            int u , v ;
            scanf("%d %d", &u, &v);
            in[u]++ ;
            add(u,v);
        }
        int k = f(n);
        if(k == -1)
            printf("-1\n");
        else
        {
            for(i = 1 ; i <= n ; i++)
            {
                for(j = 0 ; j < top ; j++)
                    if(p[j] == i)
                        break;
                if(i == n)
                    printf("%d\n", n-j);
                else
                    printf("%d ", n-j);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值