poj3368--Frequent values(RMQ)

Frequent values
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13131 Accepted: 4828

Description

You are given a sequence of n integers a1 , a2 , ... , an in non-decreasing order. In addition to that, you are given several queries consisting of indices i and j (1 ≤ i ≤ j ≤ n). For each query, determine the most frequent value among the integers ai , ... , aj.

Input

The input consists of several test cases. Each test case starts with a line containing two integers n and q (1 ≤ n, q ≤ 100000). The next line contains n integers a1 , ... , an (-100000 ≤ ai ≤ 100000, for each i ∈ {1, ..., n}) separated by spaces. You can assume that for each i ∈ {1, ..., n-1}: ai ≤ ai+1. The following q lines contain one query each, consisting of two integers i and j (1 ≤ i ≤ j ≤ n), which indicate the boundary indices for the 
query.

The last test case is followed by a line containing a single 0.

Output

For each query, print one line with one integer: The number of occurrences of the most frequent value within the given range.

Sample Input

10 3
-1 -1 1 1 1 1 3 10 10 10
2 3
1 10
5 10
0

Sample Output

1
4
3

Source

Ulm Local 2007
题目大意,求[l,r]内的出现频率最高的次数
使用数组num,num[i]表示题目中出现的的频率(输入已经是有序的),p[i]表示第i个数在那一段中,left[i]表示在一段中最左侧的序号,right表示最右侧的序号,将[l,r]内分为三部分 = right[p[l]] - l+1 ,r - left[p[r]]+1 , 和在l和r中间的完整段,对完整段使用RMQ求出最大值,找出三段中的最大值
注意,如果l,r在同一段中,结果是r-l+1;
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int b[100010][30] , num[100010] , top , p[100010] , left[100010] , right[100010];
void RMQ_init(int n)
{
    int i , j ;
    for(i = 0 ; i < n ; i++)
        b[i][0] = num[i] ;
    for(j = 1 ; (1<<j) <= n ; j++)
        for(i = 0 ; i+(1<<j)-1 < n ; i++)
            b[i][j] = max(  b[i][j-1],b[i+ (1<<(j-1) ) ][j-1] );
}
int RMQ(int l,int r)
{
    int k = 0 ;
    if(l > r)
        return 0;
    while( 1<<(k+1) <= r-l+1 )
        k++ ;
    return max( b[l][k],b[ r-(1<<k)+1 ][k] ) ;
}
int main()
{
    int i , n , m , k , a ;
    while(scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        top = 0 ;
        memset(num,0,sizeof(num));
        for(i = 0 ; i < n ; i++)
        {
            scanf("%d", &a);
            if(i == 0)
            {
                k = a ;
                num[top]++ ;
                left[0] = 0 ;
            }
            else
            {
                if(k == a)
                    num[top]++ ;
                else
                {
                    k = a ;
                    right[top] = i-1 ;
                    num[++top]++ ;
                    left[top] = i ;
                }
            }
            p[i] = top ;
        }
        right[top] = n-1 ;
        RMQ_init(top+1);
        while(m--)
        {
            int r , l ;
            scanf("%d %d", &l, &r);
            l-- ; r-- ;
            if( p[l] == p[r] )
            {
                printf("%d\n", r-l+1);
                continue;
            }
            k = 0 ;
            k = max(k,right[ p[l] ]-l+1);
            k = max(k,r-left[ p[r] ]+1  );
            k = max(k,RMQ(p[l]+1,p[r]-1));
            printf("%d\n", k);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值